More in this section
Forums / Bugs & Issues / Problem opening an old project and sitefinity error

Problem opening an old project and sitefinity error

The forums are in read-only mode. In case that you want to directly contact the Progress Sitefinity team use the support center. In our Google Plus group you can find more than one thousand Sitefinity developers discussing different topics. For the Stack Overflow threads don’t forget to use the “Sitefinity” tag.
1 posts, 0 answered
  1. Michele
    Michele avatar
    147 posts
    Registered:
    11 Jun 2009
    28 Jul 2015
    Link to this post

    Hello,

    I've to do some modification on a 5 years old project made with sitefinity, I've re-opened the solution from the svn, created a local copy from the production DB) and corrected the pointment.

    When I launch the followind error

     Invalid attribute "authenticationMode" for element "Telerik.Sitefinity.Security.Configuration.SecurityConfig". 

    and here's a part of the stacktrace

     

    [ConfigurationErrorsException: Invalid attribute "authenticationMode" for element "Telerik.Sitefinity.Security.Configuration.SecurityConfig". ] Telerik.Sitefinity.Configuration.Data.XmlConfigProvider.LoadAttributes(ConfigElement element, XmlReader reader, ConfigPolicyHandler policyHandler, String policyName, Boolean isUpgrading, Boolean isNew) +753 Telerik.Sitefinity.Configuration.Data.XmlConfigProvider.LoadElement(ConfigElement element, XmlReader reader, ConfigPolicyHandler policyHandler, String policyName, Boolean isUpgrading, Version upgradeFrom, Boolean isNew, Boolean validateTagName) +243 Telerik.Sitefinity.Configuration.Data.XmlConfigProvider.LoadSection(ConfigSection section, ConfigPolicyHandler policyHandler, String policyName) +537 Telerik.Sitefinity.Configuration.ConfigSection.Initialize(ConfigProvider provider, ConfigPolicyHandler policyHandler, String policyName, Boolean singlePolicy) +211 Telerik.Sitefinity.Configuration.ConfigProvider.GetSection(ConfigPolicyHandler policyHandler, String policyName) +170 Telerik.Sitefinity.Security.SecurityManager..cctor() +180 [TypeInitializationException: The type initializer for 'Telerik.Sitefinity.Security.SecurityManager' threw an exception.] Telerik.Sitefinity.Abstractions.Exceptions.HandleException(Exception exceptionToHandle, ExceptionPolicyName policy, Exception& exceptionToThrow) +234 Telerik.Sitefinity.Abstractions.Exceptions.HandleException(Exception exceptionToHandle, ExceptionPolicyName policy) +23 Telerik.Sitefinity.Data.ManagerBase`1.Initialize() +787 Telerik.Sitefinity.Data.ManagerBase`1..ctor(String providerName, String transactionName) +34 Telerik.Sitefinity.Localization.Res..cctor() +28 [TypeInitializationException: The type initializer for 'Telerik.Sitefinity.Localization.Res' threw an exception.] Telerik.Sitefinity.Localization.Res.RegisterResource() +0 Telerik.Sitefinity.Abstractions.ObjectFactory.RegisterStringResources() +108 Telerik.Sitefinity.Abstractions.ObjectFactory.RegisterIoCTypes() +226 Telerik.Sitefinity.Abstractions.Bootstrapper.Bootstrap() +226 Telerik.Sitefinity.Web.SitefinityHttpModule.Init(HttpApplication context) +157 System.Web.HttpApplication.RegisterEventSubscriptionsWithIIS(IntPtr appContext, HttpContext context, MethodInfo[] handlers) +530 System.Web.HttpApplication.InitSpecial(HttpApplicationState state, MethodInfo[] handlers, IntPtr appContext, HttpContext context) +304 System.Web.HttpApplicationFactory.GetSpecialApplicationInstance(IntPtr appContext, HttpContext context) +404 System.Web.Hosting.PipelineRuntime.InitializeApplication(IntPtr appContext) +475 [HttpException (0x80004005): The type initializer for 'Telerik.Sitefinity.Localization.Res' threw an exception.] System.Web.HttpRuntime.FirstRequestInit(HttpContext context) +12618692 System.Web.HttpRuntime.EnsureFirstRequestInit(HttpContext context) +159 System.Web.HttpRuntime.ProcessRequestNotificationPrivate(IIS7WorkerRequest wr, HttpContext context) +12458309

     

    What am I doing wrong? I've got no files in Logs folder

    Thanks​

     

1 posts, 0 answered