More in this section

Forums / Bugs & Issues / Problem with layout editor - removing its own float

Problem with layout editor - removing its own float

2 posts, 0 answered
  1. Orion
    Orion avatar
    54 posts
    Registered:
    02 Feb 2009
    29 Dec 2010
    Link to this post
    Hi,

    I'm either doing something wrong, or I found a bug with the new layout editor in RC2 (which I think is terrific by the way).

    Let me try to describe the best I can what's going on.

    1. In top content place holder I dragged over the 67-33 layout.  I then used the little slider to change the percentage to 72-28.
    2. I added Content Blocks to both of those areas, added my content and all is good.
    3. In the second content place holder I did the same thing but I used the 50-50 layout and left it that way, published and all is good.
    4. Then I realized that I needed more space between those two new content areas so I went into the layout editor and added right space to one, and then left space to the other.
    5. When I published, the 28% block from above has dropped down into my new area.

    After several attempts to fix and reverting back to previous version and trying again, here's what I have found using Firefox Web Developer Tools.  Before I attempt to edit the the bottom two blocks in the layout editor, the 28% block above has a class of ".sf_2cols_2_33" and this has the following styles applied to it: "floatright;  margin0; width33%;"

    As soon as I touch the layout of the bottom content areas and publish, the float: right is being removed from that 28% block.  This edit really shouldn't be affecting the content area above it like this.

    Can somebody please take a look at this?  If more detail is needed I'd be happy to provide it.

    Thanks!
    Orion


  2. Radoslav Georgiev
    Radoslav Georgiev avatar
    3370 posts
    Registered:
    01 Feb 2016
    31 Dec 2010
    Link to this post
    Hello Orion,

    Thank you for reporting this issue.

    I have managed to reproduce the problem and has logged this as a bug (#103602).

    Regards,
    Radoslav Georgiev
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
2 posts, 0 answered