More in this section

Forums / Bugs & Issues / Problems with Jquery UI

Problems with Jquery UI

2 posts, 1 answered
  1. Peter
    Peter avatar
    30 posts
    Registered:
    08 Dec 2010
    02 Mar 2011
    Link to this post
    Im building a search autocomplete using Jquery UI. Everything worked perfectly fine when I built the search in a minimal document with nothing but an input. eg:

    <input id="autocomplete" />

    and the Jquery

    <script>
         
            $( "input#autocomplete" ).autocomplete({
                    source: ['johannesburg z', 'johannesburg x', 'johannesburg v','johannesburg b','johannesburg a','johannesburg q', 'johannesburg u', 'johannesburg y', 'johannesburg o', 'johannesburg p']
            });
        </script>

    However, once I place my code into a Sitefinity 3.7 page, I get an error, telling me that "$("input#autocomplete").autocomplete" is not a function.

    This error only occurs once its in sitefinity
    Things Iv tried


    1. Im using the latest Jquery UI library (1.8.10) with the autocomplete widget.
    2. Iv checked that my file paths are correct. (they are).
    3. Used alerts eg 
    `alert("$('input#autocomplete').autocomplete")`
     - they keep returning undefined.

    Any help would be much appreciated!
  2. Georgi
    Georgi avatar
    3583 posts
    Registered:
    28 Oct 2016
    08 Mar 2011
    Link to this post
    Hello Peter,

    The problem is that we are already using jQuery to do other things, so there might be some conflicts. I suggest you taking this approach - http://api.jquery.com/jQuery.noConflict/
    Let us know if it helps.

    Best wishes,
    Georgi
    the Telerik team
    Answered
2 posts, 1 answered