More in this section

Forums / Bugs & Issues / Return Code 12031

Return Code 12031

13 posts, 0 answered
  1. Wesley
    Wesley avatar
    17 posts
    Registered:
    08 Nov 2010
    22 Mar 2011
    Link to this post
    I am recieving the error "Return Code 12031" anytime I attempt to publish a page. I am still working with the trial at this point. The site worked fine on my local development machine. The error started when I installed my local project to a windows 2003 server running IIS 6. The faster I can get this resolved the better since my client is about to purchase the licensed version today and I have to install this tomorrow morning on their servers. Any help you can give would be greatly appreciated.
  2. Abraham
    Abraham avatar
    29 posts
    Registered:
    11 Aug 2010
    23 Mar 2011
    Link to this post
    I get this error when I am trying to save a page with a description that is longer than 255 characters.
  3. Wesley
    Wesley avatar
    17 posts
    Registered:
    08 Nov 2010
    23 Mar 2011
    Link to this post
    I wish that I could report the same, it appears to be any page that is saved regardless of what is on the page or in the description. I have, however, been able to connect another sitefinity project to the same database (on a different web server) without trouble. When doing the deployment, the developer had installed a later version of the telerik rad tools and vs updated those libraries. During the deplyment the libraries had to be "downgraded" to the version that ships with sitefinity in order to work. Perhaps this has some bearing on the issue.
  4. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    12 Sep 2017
    23 Mar 2011
    Link to this post
    Hello Wesley,

    The description is set in the sf_page_data and the type of the column is nvarchar(255). You can try changing the type to nvarchar(MAX)

    Kind regards,
    Ivan Dimitrov
    the Telerik team
  5. Wesley
    Wesley avatar
    17 posts
    Registered:
    08 Nov 2010
    23 Mar 2011
    Link to this post
    This doesn't even come close to answering my inquiry. Description doesn't appear to matter as the field can be totally blank and I still get the error. I also get the error in just attempting to create a page with no attribute other than name equal to "Test".
  6. Wesley
    Wesley avatar
    17 posts
    Registered:
    08 Nov 2010
    23 Mar 2011
    Link to this post
    Ivan,

    Your answer did however get me thinking that this could just signify an error with one of the other queries. After performing a trace on the sql statements, I found that the application was attempting to insert a NULL into [sf_version_chnges].[culture]. After changing this field to accept NULL values, everything started working again. I assume that the value of this field is important somewhere, so this may just be an error in the application.
  7. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    12 Sep 2017
    25 Apr 2011
    Link to this post
    Hi ,

    If you look at the context of the second post

    "I get this error when I am trying to save a page with a description that is longer than 255 characters."

    you will see that my answer was aimed to this issue.

    Kind regards,
    Ivan Dimitrov
    the Telerik team

  8. Abraham
    Abraham avatar
    29 posts
    Registered:
    11 Aug 2010
    26 Apr 2011
    Link to this post
    Ivan,
        Thanks for answering my post even though it was not really a question.  My post was only a feeble attempt at helping.  I hope that someone could still answer Wesley's original question. 
  9. Richard
    Richard avatar
    77 posts
    Registered:
    24 Oct 2007
    18 Oct 2011
    Link to this post
    Also getting this error.  Any ideas?
  10. Victor Velev
    Victor Velev avatar
    1345 posts
    Registered:
    06 Jul 2015
    20 Oct 2011
    Link to this post
    Hello Richard,

    Please provide more information about your setup as well as the content you enter for the other fields. Supply screenshots if possible. You can log in your website and recreate the error - then attach the trace log ( or give us a link to it)  and send it to me so we can have a closer look at the service exceptions.

    All the best,
    Victor Velev
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  11. Peter From LA
    Peter From LA avatar
    6 posts
    Registered:
    10 May 2005
    05 Jun 2012
    Link to this post
    I don't know if I am coming late to this party, but since there was not good answer given, I will pile on...
    I just upgraded to 5.0 and deployed to Azure. Every time I try to publish a page I get "Returned code: 12031". It happens with old pages from the 4.4 deployment, which worked fine, and it happens with brand new pages created after the upgrade.
    I must mention that I am also not able to upload images - the uploader gives me indication that everything went well, but no images ever get uploaded. I am not sure if both things are related.
  12. Dan
    Dan avatar
    15 posts
    Registered:
    19 Dec 2011
    30 Jul 2012
    Link to this post
    I am also unable to publish any pages and get a return code 12031, i will be raising a support ticket about it but in the mean time if anyone has any ideas it would be greatly appreciated.
  13. Charles
    Charles avatar
    61 posts
    Registered:
    18 Jul 2012
    09 Aug 2012
    Link to this post
    I'm getting this attempting to edit the properties of documents.
    Login admin->click 'content'->goto documents & files->click on zip file.
    this is sitefinity 5.1.3270

    To further the troubleshooting it appears to possibly be the database/library. I can create a new library and successfully upload zip files. I can not upload zip files to the existing library. There are 600+ files in there and they are about 1-2 megs a piece. Should I switch to filesystem instead? Are there limits I'm not aware of?
13 posts, 0 answered