More in this section

Forums / Bugs & Issues / SE 4.2 fresh installation language settings errors

SE 4.2 fresh installation language settings errors

3 posts, 0 answered
  1. Markus
    Markus avatar
    2763 posts
    Registered:
    25 Nov 2005
    19 Aug 2011
    Link to this post
    I have a fresh 4.2 installation and wanted to add some front-end and back-end languages but am getting an error. I opend a ticket.

    Just wanted to know if any of you have a fresh 4.2 installation and were able to add front-end and/or back-end languages.

    Markus
  2. Markus
    Markus avatar
    2763 posts
    Registered:
    25 Nov 2005
    19 Aug 2011
    Link to this post
    I was talking with support and I thought it could have had to do with permissions on the app_data folder.

    But I get an error as well when I try to save an page.

    Any idea Markus
  3. Stanislav Velikov
    Stanislav Velikov avatar
    1113 posts
    Registered:
    18 Sep 2017
    24 Aug 2011
    Link to this post
    Hello Markus,

    This is really strange error. The possible cause is IIS configuration at the server used as host. It is hard to determine the exact host You can run service trace and supply us with the trace file(recreate the problems so they get recorded). As another option try adding a backend language manually. To do this go to  App_Data\Sitefinity\Configuration\Resources.config and add a language.
    <?xml version="1.0" encoding="utf-8"?>
    <resourcesConfig xmlns:config="urn:telerik:sitefinity:configuration" xmlns:type="urn:telerik:sitefinity:configuration:type" config:version="4.2.1650.0" multilingual="True" defaultUrlLocalizationStrategyKey="SubFolderUrlLocalizationStrategy">
        <cultures>
            <clear />
            <add culture="en" uiCulture="en" key="english-en" />
            <add culture="af" uiCulture="af" key="afrikaans-af" />
        </cultures>
        <backendCultures>
            <clear />
            <add culture="en" uiCulture="en" key="english-en" />
        </backendCultures>
        <urlLocalizationStrategySettings>
            <clear />
            <add urlLocalizationStrategyType="Telerik.Sitefinity.Localization.UrlLocalizationStrategies.SubFolderUrlLocalizationStrategy" urlLocalizationStrategyName="SubFolderUrlLocalizationStrategy">
                <urlLocalizationStrategySettings>
                    <add setting="en" cultureKey="english-en" />
                </urlLocalizationStrategySettings>
            </add>
            <add urlLocalizationStrategyType="Telerik.Sitefinity.Localization.UrlLocalizationStrategies.DomainUrlLocalizationStrategy" urlLocalizationStrategyName="DomainUrlLocalizationStrategy">
                <urlLocalizationStrategySettings>
                    <add setting="en.dinev/Wow" cultureKey="english-en" />
                </urlLocalizationStrategySettings>
            </add>
            <add urlLocalizationStrategyType="Telerik.Sitefinity.Localization.UrlLocalizationStrategies.TranslatedUrlsLocalizationStrategy" urlLocalizationStrategyName="TranslatedUrlsLocalizationStrategy" />
        </urlLocalizationStrategySettings>
    </resourcesConfig>


    All the best,
    Stanislav Velikov
    the Telerik team

    Thank you for being the most amazing .NET community! Your unfailing support is what helps us charge forward! We'd appreciate your vote for Telerik in this year's DevProConnections Awards. We are competing in mind-blowing 20 categories and every vote counts! VOTE for Telerik NOW >>

3 posts, 0 answered