More in this section

Forums / Bugs & Issues / SF 4.0 versioning and source control issue

SF 4.0 versioning and source control issue

6 posts, 0 answered
  1. Embrace
    Embrace avatar
    17 posts
    Registered:
    10 Jul 2008
    29 Jan 2011
    Link to this post
    One of our developers is having difficulty during the migration process. He sets everything up on his local box, sets up the license, DB connect strings, etc, as Sitefinity prompts. However when he moves this to our company's development server, it fails with a 404 error.

    I cannot even logon as an admin to alter the license so something else must be going on. How are we supposed to version control SF 4.0? We never had these issues with 3.7.

    Server Error in '/' Application.

    The resource cannot be found.

    Description: HTTP 404. The resource you are looking for (or one of its dependencies) could have been removed, had its name changed, or is temporarily unavailable.  Please review the following URL and make sure that it is spelled correctly. 

    Requested URL: /Sitefinity/Licensing


    Version Information: Microsoft .NET Framework Version:4.0.30319; ASP.NET Version:4.0.30319.1
  2. Embrace
    Embrace avatar
    17 posts
    Registered:
    10 Jul 2008
    29 Jan 2011
    Link to this post
    Further info: the Error.log file in ~/App_Data/Sitefinity/Logs contains this error:


    Timestamp: 1/29/2011 2:24:24 PM
        Message: The file '/SFRes/Telerik.Sitefinity.Resources.SitefinityDefault.aspx' does not exist.


       at System.Web.Compilation.BuildManager.GetVPathBuildResultInternal(VirtualPath virtualPath, Boolean noBuild, Boolean allowCrossApp, Boolean allowBuildInPrecompile, Boolean throwIfNotFound, Boolean ensureIsUpToDate)
       at System.Web.Compilation.BuildManager.GetVPathBuildResultWithNoAssert(HttpContext context, VirtualPath virtualPath, Boolean noBuild, Boolean allowCrossApp, Boolean allowBuildInPrecompile, Boolean throwIfNotFound, Boolean ensureIsUpToDate)
       at System.Web.Compilation.BuildManager.GetVirtualPathObjectFactory(VirtualPath virtualPath, HttpContext context, Boolean allowCrossApp, Boolean throwIfNotFound)
       at System.Web.Compilation.BuildManager.CreateInstanceFromVirtualPath(VirtualPath virtualPath, Type requiredBaseType, HttpContext context, Boolean allowCrossApp)
       at Telerik.Sitefinity.Web.RouteHandlerBase.CreateHandler(RequestContext requestContext, ITemplate pageTemplate)
       at Telerik.Sitefinity.Web.RouteHandlerBase.GetHttpHandler(RequestContext requestContext)
       at System.Web.Routing.UrlRoutingModule.PostResolveRequestCache(HttpContextBase context)
       at System.Web.HttpApplication.SyncEventExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute()
       at System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously)
  3. rick
    rick avatar
    4 posts
    Registered:
    14 Sep 2010
    31 Jan 2011
    Link to this post
    I get this error when I try to pre-compile the website project using C:\Windows\Microsoft.NET\Framework\v4.0.30319\aspnet_compiler.exe and deploying the resulting binaries, aspx, config, etc to a stage server.

    When doing a diff between the two directories where

    Directory_A = SiteFinity4 Empty project plus all the custom code and *.cs files
    Directory_B = aspnet_compiled version of Directory_A

    I see the following for a page that we have called Aweber.aspx.

    Below is the first line in the Aweber.aspx file in the Directory_A version
    <%@ Page Language="C#" AutoEventWireup="true" CodeFile="Aweber.aspx.cs" Inherits="Aweber" %>

    Below is the first line in the Aweber.aspx file in the Directory_B version.
    <%@ page language="C#" autoeventwireup="true" inherits="Aweber, App_Web_nrfqiyb5" %>

    I am pretty sure this is expected, since Directory_B version of this file has been pre-compiled, but could this be contributing to what we are seeing.
  4. rick
    rick avatar
    4 posts
    Registered:
    14 Sep 2010
    31 Jan 2011
    Link to this post

    Until we get some feedback on this thread, about how to compile and deploy I hacked together a deployment that deploys all cs files for our SF4 implementation.  I thought I would share this so you know what I am trying to do.  This is not a production worthy solution because we don't want to deploy cs files.  We want to pre-compile the website or move to web application project type.   Neither pre-compiling; nor web application project type have worked when compiling and only deploying binaries.

    My temporary deployment script (temporary in that is deploys the cs files which I do not want to do in the production deployment) looks something like this where
    YourAppPool - is the apppool of the SF4 application
    YourDirectory - is the physical path for the application
    YourTrunk - is the trunk url for your application.  In our case, we are using subversion.

    As you can see, I am versioning an environment specific version of each configuration file.  I don't know that this is necessary, but seem full proof until I know more about the SF4 implementation.

    appcmd recycle apppool YourAppPool
    cd C:\inetpub\wwwroot\YourDirectory
    del /s /q C:\inetpub\wwwroot\YourDirectory
    svn export YourTrunk C:\inetpub\wwwroot\YourDirectory --force
    del web.config
    copy web_stage.config web.config
    cd C:\inetpub\wwwroot\YourDirectory\App_Data\Sitefinity\Configuration
    del *.config

    rename BlogsConfig.config.stage BlogsConfig.config
    rename ContentConfig.config.stage ContentConfig.config
    rename ContentViewConfig.config.stage ContentViewConfig.config
    rename DataConfig.config.stage DataConfig.config
    rename EventsConfig.config.stage EventsConfig.config
    rename FormsConfig.config.stage FormsConfig.config
    rename LibrariesConfig.config.stage LibrariesConfig.config
    rename NewsConfig.config.stage NewsConfig.config
    rename NewslettersConfig.config.stage NewslettersConfig.config
    rename ProjectConfig.config.stage ProjectConfig.config
    rename PublishingConfig.config.stage PublishingConfig.config
    rename ResourcesConfig.config.stage ResourcesConfig.config
    rename SchedulingConfig.config.stage SchedulingConfig.config
    rename SecurityConfig.config.stage SecurityConfig.config
    rename SystemConfig.config.stage SystemConfig.config
    rename TaxonomyConfig.config.stage TaxonomyConfig.config
    rename ToolboxesConfig.config.stage ToolboxesConfig.config
    rename VersionConfig.config.stage VersionConfig.config
    rename WorkflowConfig.config.stage WorkflowConfig.config

  5. Ian
    Ian avatar
    75 posts
    Registered:
    25 Oct 2010
    01 Feb 2011
    Link to this post
    Hi

    I reported the same issue in this thread, I'm using NAnt to compile and deploy a precompiled site to the dev server via aspnet_compiler and aspnet_merge, but it is failing when the PrecompiledApp.config file is left in the root with the same error as described above. Removing the PrecompiledApp.config file allows the site to run, but that file should actually be required.

    Ryan
  6. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    12 Sep 2017
    03 Feb 2011
    Link to this post
    Hello Ryan,

    We sent a reply about this issue to you. Please check this post.

    All the best,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
6 posts, 0 answered