More in this section

Forums / Bugs & Issues / Show in Navigation not working

Show in Navigation not working

12 posts, 0 answered
  1. Rashmi
    Rashmi avatar
    27 posts
    Registered:
    04 Oct 2010
    23 Mar 2011
    Link to this post
    Hi Ivan,

    I have downloaded new Sitefinity4.0 release , and installed  on 3/18/11. But as I had informed you earlier that Show in Navigation is working as expected in Sitefinity4.0( Show in Navigation is unchecked but still that page is in navigation), and you replied that  this a bug and you are going to resolve it in next release, but I found that the bug is still not resolve in latest release too. Please let me know when this will get fixed.

    Thanks
    Rashmi
  2. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    12 Sep 2017
    23 Mar 2011
    Link to this post
    Hello Rashmi,

    I am not able to replicate the issue using the SP1 release and the latest internal build.

    Regards,
    Ivan Dimitrov
    the Telerik team
  3. Euan
    Euan avatar
    18 posts
    Registered:
    14 Oct 2010
    23 Mar 2011
    Link to this post
    Hi Ivan,

    This isn't really a bug, but I've noticed when you view/edit the page in the backend, the navigation control ignores the Show In Navigation property. So as per your video, if you edited page2, hidden would be displayed in the navigation control on the screen.

    Euan


  4. Rashmi
    Rashmi avatar
    27 posts
    Registered:
    04 Oct 2010
    25 Mar 2011
    Link to this post
    Hi Ivan,

    I followed all these steps:

    1. I have created a page in Sitefinity 4.0. I set the property Show in Navigation = false
    2. Created my own Usercontrol.
    3. Registered my UC in Sitefinity4.0
    4. Placed UC on page that I have created.

    I am  not watching my page from backend. I am loading site through IIS.

    Please find the attached image, I have circled the link in left hand side, these link navigate to the pages, I set “Show in Navigation” property of all these pages False, but still pages links are in visible in Navigation Link.

    Please let me know if i am missing any thing.

    Thanks
    Rashmi.

  5. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    12 Sep 2017
    29 Mar 2011
    Link to this post
    Hello Euan,

  6. Created my own Usercontrol.
  7. Registered my UC in Sitefinity4.0


  8. How do you populate the control with data? Do you exclude the pages that are not navigable

    App.WorkWith().Pages().Where( p => p.ShowInNavigation == True).Get().ToList();

    Regards,
    Ivan Dimitrov
    the Telerik team
  • Rashmi
    Rashmi avatar
    27 posts
    Registered:
    04 Oct 2010
    30 Mar 2011
    Link to this post

    Hi Ivan

    I am using below line of code

    oNodes = SiteMap.CurrentNode.ParentNode.ChildNodes

    SiteMap.CurrentNode.ParentNode.ChildNodes 
    return number of nodes (that contains url of pages), that should be visible in Navigation.
    This is working fine with Sitefinity 3.7, i.e if any page's property "Show in Navigation" is false then that page is not get count, only those page get count whose "Show in Navigation" property set True.

    But in Sitefintiy 4.0, even though "Show in Navigation" property is set false for any page, that page get counted.
    In my case it counts almost all the page belongs to particular group.

    I also tried by setting "Visible" Property False for the page that I don't want to show in navigation, but it's not worked.

    Thanks
    Rashmi


     

     

  • Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    12 Sep 2017
    30 Mar 2011
    Link to this post
    Hello,

    Please use the code snippet that I gave you in my last response.

    Greetings,
    Ivan Dimitrov
    the Telerik team
  • Rashmi
    Rashmi avatar
    27 posts
    Registered:
    04 Oct 2010
    31 Mar 2011
    Link to this post
    Hi Ivan

    I am not able to understand any thing with this single line of code.
    can you please send me complete code to get the count of page to show in navigation.
    also my code is in vb.net.

    Thanks
    Rashmi
  • Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    12 Sep 2017
    31 Mar 2011
    Link to this post
    Hi Euan,

    Please take a look at Pages API.


    Best wishes,
    Ivan Dimitrov
    the Telerik team
  • Rashmi
    Rashmi avatar
    27 posts
    Registered:
    04 Oct 2010
    01 Apr 2011
    Link to this post
    Hi Ivan,

    I tried with code you provided me, but i am getting below error.

    Telerik.Sitefinity.Pages.Model.PageNode, Telerik.Sitefinity.Model was not granted View in Pages for principals with IDs 00000000-0000-0000-0000-000000000000

    I repalce my code with following line of code. Error is coming at this line only.

    App

     

     

    .WorkWith().Pages().Where(Function(p) p.ShowInNavigation = True).Get().ToList


    Thanks
    Rashmi

     

  • Laura
    Laura avatar
    311 posts
    Registered:
    25 Feb 2008
    05 Apr 2011
    Link to this post
    We just updated to 4.0 SP1 and now the navigation control (horizontal drop-down out of the box) is showing the pages that should be hidden (ones with the box un-checked "Show In Navigation")  while in edit mode in the back-end only.  The front end look is working as expected. 

    This was working correctly before adding the SP 1.   What a step back... Why should I have to write code for a workaround now? Very frustrating.  Did I miss something?
  • Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    12 Sep 2017
    05 Apr 2011
    Link to this post
    Hi Laura,

    The issues has been fixed and you will not experience issues with Q1 release. Here is the PITS issue

    http://www.telerik.com/support/pits.aspx#/public/sitefinity/5302

    Kind regards,
    Ivan Dimitrov
    the Telerik team

    12 posts, 0 answered