More in this section
Forums / Bugs & Issues / This type of page is not served

This type of page is not served

The forums are in read-only mode. In case that you want to directly contact the Progress Sitefinity team use the support center. In our Google Plus group you can find more than one thousand Sitefinity developers discussing different topics. For the Stack Overflow threads don’t forget to use the “Sitefinity” tag.
2 posts, 0 answered
  1. John
    John avatar
    14 posts
    29 Jul 2010
    20 Jun 2012
    Link to this post
    This is a very basic scenerio, but for the life of me I can't figure out how to make it work in Sitefinity 5.0.

    1.  Brand new site in project manager.
    2.  Create 2 pages:  Login and Home.  Login has the non-backward compatible login control and home has a generic content block.
    3.  Backend > Pages > Permissions For All Pages > View Pages > Remove Everyone, Add Authenticated.
    4.  Backend > Pages > Login > Permissions > Break Inheritance > Add Everyone
    5.  Set Home as home page.
    6.  In Sitefinity Project Manager, browse.  I get "This type of page not served".
    7.  Change the URL to http://localhost:xxxx/TestProject/Home, I get "This type of page not served."

    **  I can login as my admin user and navigate to both pages with no problem.

    8.  I then go to Backend > Administration > Settings > Advanced > Security > Permissions > General > LoginUrl = "~/Login", log out and re-browse.  The home page does not get redirected to the login page.  I can browse it directly and see the control, but there is no redirect.

    What am I missing here?

  2. Tim
    Tim avatar
    258 posts
    22 Jun 2011
    21 Jun 2012
    Link to this post

    Here's an example of one way that people have done it. I've never used this myself but maybe it'll be of some use!
2 posts, 0 answered