More in this section
Forums / Bugs & Issues / Trouble With OpenID Authentication in Sitefinity 10

Trouble With OpenID Authentication in Sitefinity 10

The forums are in read-only mode. In case that you want to directly contact the Progress Sitefinity team use the support center. In our Google Plus group you can find more than one thousand Sitefinity developers discussing different topics. For the Stack Overflow threads don’t forget to use the “Sitefinity” tag.
3 posts, 0 answered
  1. David
    David avatar
    0 posts
    Registered:
    18 Aug 2015
    30 Mar 2017
    Link to this post

    I have downloaded and installed a brand new copy of Sitefinity 10 and am trying to test the new Social Authentication feature. I followed the instructions here (http://docs.sitefinity.com/administration-social-media) to  configure my site to use Facebook Authentication. When I attempt to register an account using the Facebook option it prompts me to enter my credentials on the Facebook site. Once I log into Facebook, it returns to my site (sitefinitytest.com/sitefinity/authenticate/openid/callback?error=access_denied), but I get a popup in Windows asking me to authenticate and is preventing me from completing the registration with Facebook.

    I get the same result with other OpenId providers as well. I have also tried this on a few different Sitefinity 10 installations and always get the same result. 

    Any help would be appreciated.

    Thanks

     

  2. Nidhi
    Nidhi avatar
    40 posts
    Registered:
    20 Jul 2010
    06 Apr 2017
    Link to this post
    We have the exact same issue - we just tried this on a new sitefinity 10 project
  3. David Rhodes
    David Rhodes avatar
    42 posts
    Registered:
    24 May 2005
    12 Apr 2017 in reply to Nidhi
    Link to this post

    Ah, same here, has anyone actually got the new auth to work yet?

    I can step through the code and see that i'm getting everything back from my STS okay but Sitefinity errors

     

    http://www.sitefinity.com/developer-network/forums/developing-with-sitefinity-/sitefinity-10-with-custom-openid-auth-provider

3 posts, 0 answered