More in this section

Forums / Bugs & Issues / Upgrade 4.1 to 4.2 Error

Upgrade 4.1 to 4.2 Error

9 posts, 0 answered
  1. Christina
    Christina avatar
    6 posts
    Registered:
    27 Jul 2011
    07 Sep 2011
    Link to this post
    After upgrading from Sitefinity 4.1 to 4.2 we are now getting an error on some of the pages that says:

    Uncaught TypeError: Cannot call method 'toLowerCase' of undefined -> Telerik.Web.UI.WebResource.axd:2072
    The front end works fine still...but editing in the Sitefinity Page Manager results in a locked page with no publish button:
  2. Victor Velev
    Victor Velev avatar
    1345 posts
    Registered:
    06 Jul 2015
    08 Sep 2011
    Link to this post
    Hi Christina,

    This is indeed a strange behaviour. Have you experienced the same behaviour when creating new pages? Also can you tell me if the affected pages are using a custom template?

    Please check if you have the following lines referencing to these particular assemblies in your webconfig file:

    <assemblies>
            <add assembly="System.Web.Routing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>
            <add assembly="System.ServiceModel, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089"/>
            <add assembly="WindowsBase, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"/>
            <add assembly="PresentationCore, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"/>
          </assemblies>

    Kind regards,
    Victor Velev
    the Telerik team

    Thank you for being the most amazing .NET community! Your unfailing support is what helps us charge forward! We'd appreciate your vote for Telerik in this year's DevProConnections Awards. We are competing in mind-blowing 20 categories and every vote counts! VOTE for Telerik NOW >>

  3. Christina
    Christina avatar
    6 posts
    Registered:
    27 Jul 2011
    08 Sep 2011
    Link to this post
    New pages do not cause any issues that I've noticed. Yes a custom template is being used.

    Also I verified that I do have those 4 lines in the web.config.

    After reviewing more...the error was throwing .toLowerCase() is undefined but the root of the problem is that the "tagName" is null that is referencing the toLowerCase() method.  Don't know if that helps at all.
  4. Jerami
    Jerami avatar
    1 posts
    Registered:
    08 Sep 2011
    10 Sep 2011
    Link to this post
    After troubleshooting the javascript and such I figured out the issue.

    In our master pages we had a content placeholder in the <head> tag:

        <asp:ContentPlaceHolder ID="HeadPlaceHolder" runat="server">
        </asp:ContentPlaceHolder>

    So the code is looking for a "form" tag and because it was beginning its loop inside the <head> tag it never found the form tag and error-ed out.
  5. Laura
    Laura avatar
    311 posts
    Registered:
    25 Feb 2008
    06 Jan 2012
    Link to this post
    I also had this problem upgrading from 4.0 to 4.4 actually. In edit mode nothing worked and in addition, the header graphics in the back-end when editing a page or template said they were missing.
    I removed the content place holder in the head tag.  This holder has always been there in previous versions.  Do you recommend not putting one in there going forward? Or is it just an upgrade issue?
  6. Victor Velev
    Victor Velev avatar
    1345 posts
    Registered:
    06 Jul 2015
    09 Jan 2012
    Link to this post
    Hi Laura,

    The problem you had with the content in the head tag is because in edit mode we are not using the ASP.NET rendering but our custom parser, which however does not support content in the head tag. The page will look ok on the front end but on the backend it will be hard for editing. Therefore we do not suggest placing content place holders in the head tag.

    Greetings,
    Victor Velev
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  7. Laura
    Laura avatar
    311 posts
    Registered:
    25 Feb 2008
    11 Jan 2012
    Link to this post
    By removing the <asp:contentplaceholder id="head" runat="server"></asp:contentplaceholder> causes problems.  We did not put any code in there on any of the pages, however, when you go to edit a page, it crashes the site.
    Only if I create  NEW template without the head tag, does it work properly.  How am I to resolve this?  I have many tempaltes that I have created off of this one master file and the site is now live.
  8. Laura
    Laura avatar
    311 posts
    Registered:
    25 Feb 2008
    11 Jan 2012
    Link to this post
    If I have any navigation on the page without the Head tags it seems to crash the site.
  9. Victor Velev
    Victor Velev avatar
    1345 posts
    Registered:
    06 Jul 2015
    11 Jan 2012
    Link to this post
    Hi Laura,

    Can you check if you experience any problems when creating a blank page ( without a template ) and drop some widgets on it? If the problem is in the template or in any of the custom controls you have you can debug the project and see where the code is breaking the project.

    Kind regards,
    Victor Velev
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
9 posts, 0 answered