More in this section

Forums / Bugs & Issues / UTC+1 not working...

UTC+1 not working...

6 posts, 0 answered
  1. Paolo
    Paolo avatar
    147 posts
    Registered:
    11 Jun 2009
    20 May 2011
    Link to this post
    Hello I've got a problem with the DateCreated / PublicationDate... in Italy we're +1, with daylight saving so we published a document at 14.30 and it appears in the dowloadlist ad 12.30.... I've tried adding

    <uiTimeZoneSettings timeZoneStandartName="W. Europe Standard Time" />

    but no luck......... I'm under SF 4.1 SP1

    Thanks
  2. Paolo
    Paolo avatar
    147 posts
    Registered:
    11 Jun 2009
    20 May 2011
    Link to this post
    I've checked and also on DB it's saved without any consideration of DB time.... my DB is UTC+1 daylight saving and it's saved as UTC ...I think it's correct, what I don't understand is why it won't format as +2 when loading even if it's set to in the systemconfig.config

    Thanks
  3. Jochem Bökkers
    Jochem Bökkers avatar
    787 posts
    Registered:
    13 Aug 2007
    20 May 2011
    Link to this post
    Paolo,

    I Haven't upgraded to this weeks SP1 yet, but the setting I've got is slightly different:
    <uiTimeZoneSettings timeZoneId="W. Europe Standard Time" />

    Perhaps they changed timeZoneId to timeZoneStandardName, but I think you're hitting a typo there with Standard and Standart.

    Good luck,
    Jochem
  4. Paolo
    Paolo avatar
    147 posts
    Registered:
    11 Jun 2009
    23 May 2011
    Link to this post
    Hello Jochem,
    I've tried your suggestion but with no luck....
    but checking the uTimeZoneSettings I've noticed that there's no timeZoneStandartName nor timeZoneId

    http://www.sitefinity.com/40/help/developers-guide/properties_t_telerik_sitefinity_services_timezoneuisettings.html


    what should I do?
    Thanks
  5. Lubomir Velkov
    Lubomir Velkov avatar
    688 posts
    Registered:
    03 Nov 2014
    27 May 2011
    Link to this post
    Hello Paolo,

    You can edit the template for the download list and for example replace and this:

    <sitefinity:TextField runat=\"server\" DisplayMode=\"Read\" Value='<%# ((DateTime)Eval(\"DateCreated\")).ToLocalTime() %>' />

    This should display the DateCreated field with the current local time.

    Best wishes,
    Lubomir Velkov
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  6. Paolo
    Paolo avatar
    147 posts
    Registered:
    11 Jun 2009
    27 May 2011
    Link to this post
    Hello Lubomir,
    I've found a similar solution by myself but it's a workaround... I attend that setting it in the Administration->Setting would apply this to each datetime I display, it threats, in the project...
6 posts, 0 answered