More in this section

Forums / Bugs & Issues / 3.6 Community -- error creating new pages

3.6 Community -- error creating new pages

4 posts, 0 answered
  1. Michael
    Michael avatar
    17 posts
    12 Oct 2008
    13 Feb 2009
    Link to this post
    I get the following error when trying to add a new page:

    Procedure or function 'sf_CmsPageProps_ins' expects parameter '@P_MenuName', which was not supplied.

    Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

    Exception Details: System.Data.SqlClient.SqlException: Procedure or function 'sf_CmsPageProps_ins' expects parameter '@P_MenuName', which was not supplied.

    Source Error:

    An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.

    Stack Trace:

    [SqlException (0x80131904): Procedure or function 'sf_CmsPageProps_ins' expects parameter '@P_MenuName', which was not supplied.]
       Nolics.ORMapper.DataProviders.SQLBlockBuilder.EndStatement(SQLCommandEventArgs args, DataRow row) +557
       Nolics.ORMapper.DataProviders.SQLBlockBuilder.ExecCommandProcedure(StmtContext context, DataRow data) +1497
       Nolics.ORMapper.DataProviders.SQLBlockBuilder.ExecuteCommand(StmtContext context, DataRow data) +95
       Nolics.ORMapper.DataProviders.SQLDataProvider.Update(DataSet updateData) +754
       Nolics.ORMapper.Base.Transaction.Commit(Boolean fCleanIfSuccess) +1418
       Nolics.ORMapper.Base.Transaction.Commit() +34
       Telerik.Cms.Data.DefaultProvider.SavePage(IPage page) +1184
       Telerik.Cms.CmsManager.SavePage(IPage page) +61
       Telerik.Cms.Web.UI.PageProperties.editCnt_Command(Object sender, CommandEventArgs e) +5005
       Telerik.Cms.Web.UI.GenericContainer`1.OnCommand(Object sender, CommandEventArgs e) +105
       Telerik.Cms.Web.UI.GenericContainer`1.OnBubbleEvent(Object source, EventArgs args) +150
       System.Web.UI.Control.RaiseBubbleEvent(Object source, EventArgs args) +37
       System.Web.UI.WebControls.LinkButton.OnCommand(CommandEventArgs e) +118
       System.Web.UI.WebControls.LinkButton.RaisePostBackEvent(String eventArgument) +135
       System.Web.UI.WebControls.LinkButton.System.Web.UI.IPostBackEventHandler.RaisePostBackEvent(String eventArgument) +10
       System.Web.UI.Page.RaisePostBackEvent(IPostBackEventHandler sourceControl, String eventArgument) +13
       System.Web.UI.Page.RaisePostBackEvent(NameValueCollection postData) +175
       System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +1565

  2. Chris
    Chris avatar
    57 posts
    12 Nov 2008
    17 Feb 2009
    Link to this post
    Hi Michael, did you do a fresh installation or did you update an existing Sitefinity 3.5 website?

    I had the same issue on our development server when I updated our existing Sitefinity 3.5 installation to 3.6. It turned out that the database was only updated partially, leaving some of the stored procedures in a non-working state. In my case, the stored procedure that threw the error had not been updated at all.
    On my local development machine, everything had worked fine though. And since I had copied the databases before the update, I could just copy it back from my machine to the development server which fixed the issue.
    Since those stored procedures don't hold any data, you might want to try the following:
    - Create a new database and do a fresh installation of version 3.6 in there.
    - Copy all the stored procedures from this database into your current database.

    Unfortunately, I could not find any scripts that would update an existing 3.5 database to 3.6 without manual labor.

    Cheers, Chris
  3. Georgi
    Georgi avatar
    3583 posts
    28 Oct 2016
    17 Feb 2009
    Link to this post

    Are you upgrading the projects in full trust environment? The database should be upgraded in full trust always, otherwise it might not be upgraded.

    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Check out the tips for optimizing your support resource searches.
  4. Michael
    Michael avatar
    17 posts
    12 Oct 2008
    17 Feb 2009
    Link to this post
    I used the upgrade patch, not a clean install.  I would presume that my problem was the same as yours, in that certain SPs were not updated.  I am working in a full-trust environment.

    To resolve the issue, I did the following:

    I deleted all SF tables, SPs and UDFs from my DB.  I then created a fresh install of the code using the blank project.  I ran that and all seemed to be fine.  I then added my code to this new project and all was fine.

    This meant, however, that I had to rebuild the sitemap from scratch.  This was only a minor inconvenience for me as I had a small site map to begin with.

    Thanks for looking into this.

Register for webinar
4 posts, 0 answered