More in this section
Forums / Bugs & Issues / Active Directory Issue

Active Directory Issue

The forums are in read-only mode. In case that you want to directly contact the Progress Sitefinity team use the support center. In our Google Plus group you can find more than one thousand Sitefinity developers discussing different topics. For the Stack Overflow threads don’t forget to use the “Sitefinity” tag.
2 posts, 0 answered
  1. Richard Baugh
    Richard Baugh avatar
    201 posts
    22 Aug 2012
    02 Aug 2010
    Link to this post
    I am having an issue with an old 3.1 site. Previously, we  have had a 3.1 site setup and running with Active Directory for the membership and roles sections. Now we are running into an issue when pages are requesting a list of users from AD. (Dashboard, Users) To be more specific, here is the error:
    [ProviderException: Property 'userAccountControl' not found.]
       System.Web.Security.PropertyManager.GetSearchResultPropertyValue(SearchResult res, String propertyName) +3291110
       System.Web.Security.ActiveDirectoryMembershipProvider.GetMembershipUserFromSearchResult(SearchResult res) +695
       System.Web.Security.ActiveDirectoryMembershipProvider.FindUsers(DirectoryEntry containerEntry, String filter, String sortKey, Int32 pageIndex, Int32 pageSize, Int32& totalRecords) +892
       System.Web.Security.ActiveDirectoryMembershipProvider.FindUsersByName(String usernameToMatch, Int32 pageIndex, Int32 pageSize, Int32& totalRecords) +904
       System.Web.Security.ActiveDirectoryMembershipProvider.GetAllUsers(Int32 pageIndex, Int32 pageSize, Int32& totalRecords) +78
       Telerik.Security.UserManager.GetAllUsers(Int32 from, Int32 maxRows, String sortExpr, Int32& totalRows) +195
       Telerik.Security.WebControls.UsersDataSourceView.ExecuteSelect(DataSourceSelectArguments arguments) +207
       System.Web.UI.DataSourceView.Select(DataSourceSelectArguments arguments, DataSourceViewSelectCallback callback) +27
       System.Web.UI.WebControls.DataBoundControl.PerformSelect() +261
       System.Web.UI.WebControls.BaseDataBoundControl.EnsureDataBound() +82
       System.Web.UI.WebControls.CompositeDataBoundControl.CreateChildControls() +95
       System.Web.UI.Control.EnsureChildControls() +146
       System.Web.UI.WebControls.GridView.get_Rows() +46
       Telerik.Security.WebControls.ManageUsers.OnPreRender(EventArgs e) +140
       System.Web.UI.Control.PreRenderRecursiveInternal() +108
       System.Web.UI.Control.PreRenderRecursiveInternal() +224
       System.Web.UI.Control.PreRenderRecursiveInternal() +224
       System.Web.UI.Control.PreRenderRecursiveInternal() +224
       System.Web.UI.Control.PreRenderRecursiveInternal() +224
       System.Web.UI.Control.PreRenderRecursiveInternal() +224
       System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +3394

    I decided to run some tests. I setup an empty site using the latest 3.7 SP3. Once I got the site setup, I went in and made the changes in order to run AD. Once the changes were complete, I then tried to log into the admin section. This time, I was able to login and see the dashboard. I was also able to go to the users page under administration. Both of these pages are failing in the 3.1 application. Looking at the stack trace, it seems that the problem is related to AD and .net. So for grins I setup a 3.1 site to test. I thought maybe there was something within the troubled site that was causing the problem. When I setup a new 3.1 site and then changed the web.config to allow fo Ad in membership and roles, I ran into the same error.

    I even opened up ADSI edit and logged in with the credentials we are using in the site. I was able to navigate to all users that would have access to the site and was able to see the 'userAccountControl' property. So I know that the user being used to connect to AD is ok. This was also confirmed when the 3.7 site was setup and was able to connect to the admin pages.

    So it seems that I am getting this error on 3.1 sites and not on a 3.7 site. I was wondering if this is something you have come across before or might have some ideas. Unfortunately this site is not in a position to migrate to 3.7. So we are stuck with trying to figure if there is anything that we can do. Maybe override a class??

  2. Radoslav Georgiev
    Radoslav Georgiev avatar
    3370 posts
    01 Feb 2016
    04 Aug 2010
    Link to this post
    Hello Richard Baugh,

    Thank you for contacting Telerik Support.

    The issue is in the implementation on of the Sitefinity 3.1 Active Directory membership provider. Since then we have rewritten the provider completely at least once. Unfortunately fixing this issue would not be as easy as overriding a single class. This will involve rewriting the membership provider, the UserManager class as well as the web controls used into the Sitefintiy backend. Our suggestion would be to download a version of Sitefinity which is closer to the one you are using - Sitefinity 3.2 for example and see if the error will manifest there. Upgrading the website to such a version will be quicker and less painful.

    Radoslav Georgiev
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
2 posts, 0 answered