More in this section

Forums / Bugs & Issues / medium trust - security exceptions

medium trust - security exceptions

2 posts, 0 answered
  1. Miran Zgec
    Miran Zgec avatar
    19 posts
    06 Oct 2006
    01 Jul 2008
    Link to this post

    Some time ago I've set up page using  Sitefinity Version 3 .1 SP2 on shared hosting enviromen, using medium trust support. I've set it up like suggested - first on localhost, enabling all modules, then copied everything on remore host.

    the site worked fine for about 4 months, then security exception occured - something about medium hosting enviroment and not enough rights.

    I wrote to server suport, and all they did, they renamed Global.asax to Global.asax_old and the site was up and running  ....  for a day than it crashed again. Now It works for about a day, then it throws security exception again. I rename Global.asax and It works again. I noticed that also if I change something in web.config it starts to work again.

    It looks to me like some script wants to do some functionality not allowed by medium trust, but not all the time, just about in a day interval.

    Have any quick solutions. I realy don't wanna set up everithing again in localhost and then copy on remote, since the page has quite a lot of data (pages, news) entered by now.

    Thank you

  2. Nikifor
    Nikifor avatar
    232 posts
    18 May 2013
    03 Jul 2008
    Link to this post
    Hi Miran Zgec,

    The exception you have received is a known issue with Sitefinity 3.1 SP2 used in the Medium Trust Environment. There are sporadic automatic upgrades in the life cycle of a project database. However, when used in Medium Trust, these upgrades fail. We have made a lot of improvements for running Sitefinity in Medium Trust so now it is fully supported with the current version of Sitefinity - 3.2 SP2 HF1616.

    We recommend upgrading your project to the latest official release so that you would not experience this problem any more.

    Hope this helps.

    Best wishes,
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
2 posts, 0 answered