More in this section
Forums / Deployment / Could not load file or assembly 'Telerik.Sitefinity' or one of its dependencies

Could not load file or assembly 'Telerik.Sitefinity' or one of its dependencies

The forums are in read-only mode. In case that you want to directly contact the Progress Sitefinity team use the support center. In our Google Plus group you can find more than one thousand Sitefinity developers discussing different topics. For the Stack Overflow threads don’t forget to use the “Sitefinity” tag.
2 posts, 0 answered
  1. RichW
    RichW avatar
    20 posts
    11 Feb 2011
    13 Apr 2011
    Link to this post
    Just encountered this error and fixed it so thought I'd share the solution and hopefully save anyone some headaches.

    Basically this occurs when choosing to do a solution rebuild in Visual Studio. VS removes some dll from the bin directory and you will then be presented with the above error when browsing the site.

    To fix this, replace the bin folder from a svn repo if you have one. Alternatively create a new sitefinity project and copy the bin folder from that and copy it into your project. One thing to remember is to back up your site's bin folder.

  2. Ilan
    Ilan avatar
    12 posts
    26 Oct 2015
    28 Jan 2016
    Link to this post
    Thank you! This is what solved my problem
2 posts, 0 answered