More in this section
Forums / Deployment / Deploying problems

Deploying problems

The forums are in read-only mode. In case that you want to directly contact the Progress Sitefinity team use the support center. In our Google Plus group you can find more than one thousand Sitefinity developers discussing different topics. For the Stack Overflow threads don’t forget to use the “Sitefinity” tag.
5 posts, 0 answered
  1. Pik Lee
    Pik Lee avatar
    142 posts
    Registered:
    13 Aug 2012
    25 Mar 2011
    Link to this post
    I am trying to migrate an existing Sitefinity project from my local machine to virtual server, the first page is display correctly with the login control.

    After I entered the correct username and password, I am getting a 404 error message.

    The sql server I used in my local machine is MS SQL server database. I want the site points to the same  MS SQL server database as the one I used in my local machine. Do I need to change the database connection string?

    Thanks, ~Pik
  2. Pik Lee
    Pik Lee avatar
    142 posts
    Registered:
    13 Aug 2012
    26 Mar 2011
    Link to this post
     After I deployed the project to production environment, it only goes to the "home page".  Everypage I try to go I received 404 error message, even for those pages in the same folder level as "home page". It is working fine on my local machine.  Not sure what did I do wrong. Anyone has any idea?  Thanks, ~ Pik
  3. Pik Lee
    Pik Lee avatar
    142 posts
    Registered:
    13 Aug 2012
    26 Mar 2011
    Link to this post
    Fixed the issue. It was the IIS setting.  Thanks, ~Pik
  4. kevin
    kevin avatar
    6 posts
    Registered:
    19 Nov 2007
    19 Aug 2011
    Link to this post
    What setting did u fix exactly? I am having the same exact issue.
  5. Pik Lee
    Pik Lee avatar
    142 posts
    Registered:
    13 Aug 2012
    19 Aug 2011
    Link to this post
    In iis, under "Directory Security" tab, click on the Edit button on "Authentication and access control" . I unchecked "Integrated Windows authentication". 

    Hope this helps.
    ~PIk
5 posts, 0 answered