More in this section

Forums / Deployment / access issue after upgrade to VS2010 & .NET 4

access issue after upgrade to VS2010 & .NET 4

8 posts, 0 answered
  1. Nick
    Nick avatar
    91 posts
    Registered:
    04 Aug 2008
    28 Apr 2010
    Link to this post
    Hi!

    We had an instance of sitefinity running on a virtual server which was working perfectly fine. After upgrading to VS2010 / .NET 4 a problem has suddenly occurred. An exception is thrown everytime the website is browsed. Whilst the exception seems to point to a permissions error, this does not appear to be the case as we have given full control to all users to rule this out, and this has not resolved the issue.

    The exception is as follows:

    Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

    Parser Error Message: Could not load file or assembly 'Telerik.Framework, Version=3.2.1616.2, Culture=neutral, PublicKeyToken=dfeaee0e3978ac79' or one of its dependencies. Access is denied.

    Source Error:

     

    Line 131:      </eventMappings>

    Line 132:      <providers>

    Line 133:        <add name="Simple Web Event Provider" type="Telerik.Utilities.TextFileWebEventProvider,Telerik.Framework" logFileName="~/App_Data/sitefinity.log"/>

    Line 134:        <add name="Simple Web Buffered Event Provider" type="Telerik.Utilities.BufferedTextFileWebEventProvider,Telerik.Framework" bufferMode="Notification" logFileName="~/App_Data/sitefinity.log"/>

    Line 135:        <add name="Code Benchmark Provider" type="Telerik.Utilities.CodeBenchmarkTextFileProvider,Telerik.Framework" enabled="False" logFileName="~/App_Data/performance.log"/>


    Source File: C:\Inetpub\contentApp\web.config    Line: 133

    Assembly Load Trace: The following information can be helpful to determine why the assembly 'Telerik.Framework' could not be loaded.

    Any idea why this may be causing a problem? We are using Sitefinity 3.2 SP2 - i know we need an upgrade, but we're too tied down in our environment at the moment :-)

    Thanks,
    Nick
  2. Radoslav Georgiev
    Radoslav Georgiev avatar
    3370 posts
    Registered:
    01 Feb 2016
    28 Apr 2010
    Link to this post
    Hello Nick,

    Thank you for using our services.

    Sitefinity 3.2 is a .NET 2.0 application. This means that your website should target the .NET 2.0 framework. It does not support .NET 4.0, as a matter of fact no Sitefinity 3.x version supports .NET 4.0. You can use Sitefinity 3.2 with Visual Studio 2010, however you should not set the project to target .NET 4.0 when you are asked to do this in VS 2010. Also make sure that the bin folder contains the Telerik.Framework assembly.

    Regards,
    Radoslav Georgiev
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
  3. Nick
    Nick avatar
    91 posts
    Registered:
    04 Aug 2008
    28 Apr 2010
    Link to this post
    Hi Radoslav :-)

    We are not trying to use VS2010 to open the solution, we are merely trying to host in IIS6 after upgrading the .NET runtime and are seeing this error. We have attempted to disable .NET 4 since the upgrade in case it was wrongly targetting that version but the error still occurrs. We have also checked that the bin folder contains that specific assembly - which is does!

    Our last option (pending help from you wonderful people!) is to completely remove the website, uninstall .NET 4 and start again - perhaps this time installing .NET 4 before setting up the website.

    Any further suggestions will be much appreciated,
    Thanks,
    Nick
  4. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    12 Sep 2017
    28 Apr 2010
    Link to this post
    Hello Nick,

    ASP.NET account does not have permissions to Telerik.Framework.dll

    Parser Error Message: Could not load file or assembly 'Telerik.Framework, Version=3.2.1616.2, Culture=neutral, PublicKeyToken=dfeaee0e3978ac79' or one of its dependencies. Access is denied.


    All the best,
    Ivan Dimitrov
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
  5. Nick
    Nick avatar
    91 posts
    Registered:
    04 Aug 2008
    29 Apr 2010
    Link to this post
    thanks for the reply Ivan,
    As i say, we did try modifying access permissions because i expected the problem would be as such. Giving elevated permissions did not seem to work, so as a final solution we attempted to give all users full control just to see if that would solve things - which it didn't :-(

    The application was working perfectly before the .NET 4 upgrade, do you think it is possible that this may have had an effect on folder permissions?

    Thanks again,
    Nick
  6. Georgi
    Georgi avatar
    3583 posts
    Registered:
    28 Oct 2016
    29 Apr 2010
    Link to this post
    Hello Nick,

    It still looks like an permissions issue. 
    Could you please check which user account is being used by the application pool, serving the web site? Then you can try to use another user for that pool, just for the test.

    Regards,
    Georgi
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
  7. S1000RR
    S1000RR avatar
    1 posts
    Registered:
    22 Oct 2012
    25 May 2010
    Link to this post
    the app_data folder is now located under \bin ...
    we had the same problem whil upgrading from vs2008 net 2 to vs2010 and net4

    best regards
  8. Nick
    Nick avatar
    91 posts
    Registered:
    04 Aug 2008
    25 May 2010
    Link to this post
    thanks for that R1, so what was the solution you employed to resolve this issue?
Register for webinar
8 posts, 0 answered