More in this section
Forums / Designing with Sitefinity / PollBox LayoutTemplatePath Property

PollBox LayoutTemplatePath Property

The forums are in read-only mode. In case that you want to directly contact the Progress Sitefinity team use the support center. In our Google Plus group you can find more than one thousand Sitefinity developers discussing different topics. For the Stack Overflow threads don’t forget to use the “Sitefinity” tag.
5 posts, 2 answered
  1. Eric Wallace
    Eric Wallace avatar
    66 posts
    Registered:
    08 Oct 2009
    14 Apr 2010
    Link to this post
    I am trying to customize the layout of the PollBox control. However, setting the LayoutTemplatePath property of the PollBox control does nothing. Is this a known issue?
  2. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    12 Sep 2017
    14 Apr 2010
    Link to this post
    Hello Eric Wallace,

    Have you tried to use ControlsConfig file to map the template - How to map a template

    <!--Gets or sets the path to a custom layout template for the PollBox control.-->
        <viewSettings hostType="Telerik.Polls.WebControls.PollBox" layoutTemplatePath="~/Sitefinity/ControlTemplates/Polls/PollBox.ascx" />


    Kind regards,
    Ivan Dimitrov
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
    Answered
  3. Eric Wallace
    Eric Wallace avatar
    66 posts
    Registered:
    08 Oct 2009
    14 Apr 2010
    Link to this post
    That is not working either. My directory structure is:
    App_Data
    - Configuration
    -- Telerik.Sitefinity.Configuration.ControlsConfig.xml

    The contents of the xml file are:
    <?xml version="1.0" encoding="utf-8" ?>
    <controlsConfig>
      <viewMap>
        <viewSettings hostType="Telerik.Polls.WebControls.PollBox"
    layoutTemplatePath="~/Sitefinity/ControlTemplates/Polls/HaveYourSay.ascx">
        </viewSettings>
      </viewMap>
    </controlsConfig>

    It seems as though SF is not picking up that configuration file. Is there anything that needs to be modified in web.config to get that xml file working properly?
  4. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    12 Sep 2017
    14 Apr 2010
    Link to this post
    Hello Eric Wallace,

    Have you restarted the application as suggested in the KB?

    Greetings,
    Ivan Dimitrov
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
    Answered
  5. Eric Wallace
    Eric Wallace avatar
    66 posts
    Registered:
    08 Oct 2009
    14 Apr 2010
    Link to this post
    That's exactly what it was Ivan, it got picked up after an iis reset. Thanks a ton man.
    - Eric
Register for webinar
5 posts, 2 answered