More in this section

Forums / Developing with Sitefinity / AD for Membership provider, but use Default Role provider.

AD for Membership provider, but use Default Role provider.

3 posts, 0 answered
  1. David
    David avatar
    15 posts
    Registered:
    22 Jun 2011
    10 Feb 2012
    Link to this post
    How would you recommend I implement the Active Directory as my Membership Provider, but use Sitefinity's Default Role Provider? My organizations Role hierarchy is too complicated to manage through AD and we would like to only use the membership provider

    We had this implemented with 3.7using a custom sitefinity/login.asp but I cannot configure the ldapConnection without a rolesDns and/roleFilter

    Thank you,

    David
  2. Lubomir Velkov
    Lubomir Velkov avatar
    688 posts
    Registered:
    03 Nov 2014
    14 Feb 2012
    Link to this post
    Hello David,

    Could you please elaborate on "I cannot configure the ldapConnection without a rolesDns and/roleFilter"? You can assign roles from the default role provider to users from your AD provider - you don't have to assign them roles only from the AD roles. When configuring the LDAP connection you can leave the entries for the roles blank or with some default values.

    Regards,
    Lubomir Velkov
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. David
    David avatar
    15 posts
    Registered:
    22 Jun 2011
    02 Mar 2012
    Link to this post
    After working on this for some time, I was able to get a configuration that worked.
    I wanted to use the default Role Provider but enable the Membership provider based on AD.
    I was unable to leave the entries blank because the CMS would give an error message stating these fields could not be blank. I was able to leave the default values, and after configuring my AD integration I did not enable the Role Provider and everything seems to be working as expected.

    Thank you,

    David
3 posts, 0 answered