More in this section

Forums / Developing with Sitefinity / Cant get thunder work.

Cant get thunder work.

5 posts, 0 answered
  1. Just64
    Just64 avatar
    10 posts
    Registered:
    24 Jul 2012
    12 Jul 2012
    Link to this post
    After i connect to my SF and tells me that the connection was successful when i close the "connect to SF project" windows it say me  that the initializing of the connection failed....
  2. SelAromDotNet
    SelAromDotNet avatar
    912 posts
    Registered:
    18 Jul 2012
    12 Jul 2012
    Link to this post
    Be sure that you are using the same version of Sitefinity Thunder in both Visual Studio and your Sitefinity website.

    Thunder has two components, the VS extension and the SF module. After installing/updating Thunder in VS you can install the updated SF module to your website in the Telerik Menu so they are the same version.

    Hope this is helpful!
  3. Just64
    Just64 avatar
    10 posts
    Registered:
    24 Jul 2012
    16 Jul 2012
    Link to this post
    If i instal the Thunder service with the "Install Sitefinity Thunder Module" it work OK. But every time i compile my solution i have to install again the module to get Thunder work again.

    ALSO if the ToolboxesConfig.config is denied for edit, thunders gives u an error and crashes the Visual studio.
  4. Ferdi
    Ferdi avatar
    9 posts
    Registered:
    17 May 2012
    23 Jul 2012
    Link to this post
    I cannot get Thunder to work neither. With a previous version the same scenario as Just64 happens: every time the solution is recompiled, the Thunder service had to be installed again before it worked.

    With the newest version (1.1.4.0) it is not working anymore at all. After installing the service into the project, and clicking connect, the following error message appears:

    Locating source for 'c:\Tests\CMS\Sitefinity.CI.Thunder.Module.CodeBase\Sources\Telerik.Sitefinity.Thunder.Module\Services\ThunderService.cs'. Checksum: MD5 {68 2d 7f f9 6d 1a d2 d6 3e d3 9f b8 a9 cd 31 89}
    The file 'c:\Tests\CMS\Sitefinity.CI.Thunder.Module.CodeBase\Sources\Telerik.Sitefinity.Thunder.Module\Services\ThunderService.cs' does not exist.
    Looking in script documents for 'c:\Tests\CMS\Sitefinity.CI.Thunder.Module.CodeBase\Sources\Telerik.Sitefinity.Thunder.Module\Services\ThunderService.cs'...
    Looking in the projects for 'c:\Tests\CMS\Sitefinity.CI.Thunder.Module.CodeBase\Sources\Telerik.Sitefinity.Thunder.Module\Services\ThunderService.cs'.
    The file was not found in a project.
    Looking in directory 'C:\Program Files (x86)\Microsoft Visual Studio 10.0\VC\crt\src\'...
    Looking in directory 'C:\Program Files (x86)\Microsoft Visual Studio 10.0\VC\atlmfc\src\mfc\'...
    Looking in directory 'C:\Program Files (x86)\Microsoft Visual Studio 10.0\VC\atlmfc\src\atl\'...
    Looking in directory 'C:\Program Files (x86)\Microsoft Visual Studio 10.0\VC\atlmfc\include\'...
    The debug source files settings for the active solution indicate that the debugger will not ask the user to find the file: c:\Tests\CMS\Sitefinity.CI.Thunder.Module.CodeBase\Sources\Telerik.Sitefinity.Thunder.Module\Services\ThunderService.cs.
    The debugger could not locate the source file 'c:\Tests\CMS\Sitefinity.CI.Thunder.Module.CodeBase\Sources\Telerik.Sitefinity.Thunder.Module\Services\ThunderService.cs'.

    Note that I have no directory "c:\Tests\CMS\...." on my machine.

    The error shows up using either Development Server and IIS Express, on the localhost domain.
    The configuration directory is open to write for all users.
  5. Just64
    Just64 avatar
    10 posts
    Registered:
    24 Jul 2012
    24 Jul 2012
    Link to this post
    Now i try to connect to a server, not to local, and inside the connection setting editor the test connection says "connected successfully", when i close the "connect to SF project" in VS the initializing of that connection fails.
    Also the "download" button does nothing.
5 posts, 0 answered