More in this section
Forums / Developing with Sitefinity / Categories Issues in Custom Module

Categories Issues in Custom Module

The forums are in read-only mode. In case that you want to directly contact the Progress Sitefinity team use the support center. In our Google Plus group you can find more than one thousand Sitefinity developers discussing different topics. For the Stack Overflow threads don’t forget to use the “Sitefinity” tag.
1 posts, 0 answered
  1. Claude Heidgerken
    Claude Heidgerken avatar
    1 posts
    Registered:
    03 Dec 2009
    20 Jul 2012
    Link to this post
    I'm trying to display the category of each item in a list of items from a custom module. I have tried to accomplish this 2 way with little success.  
    Method 1:
    If I try to insert "Category" snippet from under the Other Data drop-down on the edit control page, I get "Telerik.OpenAccess.TrackedList`1[System.Guid] " as output on each item.

    Method 2:
    I have also tried to paste the snippet that works fine on the Full View Template. Which looks like this:
    <sf:SitefinityLabel runat="server" Text='Categories:' WrapperTagName="div" HideIfNoText="true" CssClass="sfitemFieldLbl" />
                    <sf:HierarchicalTaxonField runat="server" DisplayMode="Read" WebServiceUrl="~/Sitefinity/Services/Taxonomies/HierarchicalTaxon.svc" TaxonomyId="e5cd6d69-1543-427b-ad62-688a99f5e7d4" Expanded="false" TaxonomyMetafieldName="Category" BindOnServer="true" />

    That renders on the page correctly but ALWAYS locks my page that is using the list control in the sitefinity backend so that I cannot make any changes to it.  No links work, can't edit any modules, no publish button.  Have to use the back button to get out of the edit screen.  As soon as I remove the above snippet from the list template the page is unlocked and edits just fine in the backend.

    Any ideas of what I'm doing wrong?

    Thanks  
1 posts, 0 answered