More in this section
Forums / Developing with Sitefinity / Content Blocks Inline Styles

Content Blocks Inline Styles

The forums are in read-only mode. In case that you want to directly contact the Progress Sitefinity team use the support center. In our Google Plus group you can find more than one thousand Sitefinity developers discussing different topics. For the Stack Overflow threads don’t forget to use the “Sitefinity” tag.
3 posts, 0 answered
  1. Enas
    Enas avatar
    0 posts
    Registered:
    25 Feb 2016
    18 Aug 2016
    Link to this post
    Hi, I am new to Sitefinty and I have instructed the client to use paste form word option to clear the Inline styles , but even after that the inline styles are there (after publish) . so I had to instruct them to use "strip CSS style" and even "Strip all Styles" form the advance options . but this also is not clearing all the inline styles .. I am not sure if this is normal ! and if there is anything else that I could do to disable the Inline styles while copying from an existing resource , please advise,
  2. Steve
    Steve avatar
    3037 posts
    Registered:
    03 Dec 2008
    18 Aug 2016
    Link to this post

    Which editor are they using?   If it's the RadEditor, then you can set defaults and they dont need to worry about it.  If it's the new Feather MVC content editor, such functionality doesn't yet exist.

     

    /Sitefinity/Administration/Settings/Advanced/Appearance

    Set: Rad Editor strip formatting options
    Value: MSWordRemoveAll, Css, Font, Span

    Set: Rad Editor's content filters
    Value: FixEnclosingP, ConvertFontToSpan, IndentHTMLContent

  3. Enas
    Enas avatar
    0 posts
    Registered:
    25 Feb 2016
    21 Aug 2016 in reply to Steve
    Link to this post

    I found the Strip formatting options is already set to the provided value , I have changed the filter settings . I hope that this is will fix the issue .

    Thank you !

3 posts, 0 answered