More in this section

Forums / Developing with Sitefinity / CPU and memory issue in Sitefinity 4.3

CPU and memory issue in Sitefinity 4.3

4 posts, 0 answered
  1. Stephen
    Stephen avatar
    70 posts
    Registered:
    09 Jun 2009
    16 Dec 2011
    Link to this post
    Hi,
    I have website in Sitefinity 4.3 it seems like it is eating lots of memories then after a while I have to restart the website on IIS. Please help me

    In Windows Task Manager, this website strikes . 425 MB of memory and 99% of CPU resources (both cores maxed).
  2. Steve
    Steve avatar
    3037 posts
    Registered:
    03 Dec 2008
    17 Dec 2011
    Link to this post
    That memory looks right, it'll even run higher (potentially)

    You shouldn't be hitting 99% on the reload of a page though, PERHAPS the first time a page is built, but after that it's just coming from the cache (you do have the cache still enabled right?)
  3. Markus
    Markus avatar
    2763 posts
    Registered:
    25 Nov 2005
    19 Dec 2011
    Link to this post
  4. Tihomir
    Tihomir avatar
    23 posts
    Registered:
    09 Dec 2016
    22 Dec 2011
    Link to this post
    Hi,

     
    Are you reproducing this issue within the front-end or within the back-end? Also are there any custom modules or custom widgets within your website? 

    In general we need detailed information about the exact steps needed for reproducing this issue. Once the info is provided we will try to track down the issue and we will find a proper solution.


    Kind regards,
    Tihomir
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
4 posts, 0 answered