More in this section

Forums / Developing with Sitefinity / disable urlevaluationmode on widget

disable urlevaluationmode on widget

4 posts, 0 answered
  1. sacparker
    sacparker avatar
    14 posts
    Registered:
    21 Mar 2007
    14 Nov 2011
    Link to this post
    Hi All,

    I am using the news widget to show a list of news items and then once selected the details of a news item is shown on the same page. Is there any way to disable the urlevaluationmode on a widget so that the "list" widget does not filter? I want the users to be able to see the list and the detail of one item on the same page.

    thanks!
  2. Boyan Barnev
    Boyan Barnev avatar
    1429 posts
    Registered:
    30 Oct 2017
    17 Nov 2011
    Link to this post


    Hello Sacparker,

    You can easily configure this by setting one of the widget's ContentViewDisplayMode property to be "Master" and the other - "Detail". This will automatically force the Master widget to stop url queries, and the Details widget will display nothing (or a single item in DetilsView, depending on how you configure it) until a URLquery is passed by the Master widget. I'm attaching a short video demonstrating how to set this functionality, please refer to it for more detailed information. If you have any additional questions, please let us know.



    All the best,
    Boyan Barnev
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. sacparker
    sacparker avatar
    14 posts
    Registered:
    21 Mar 2007
    18 Nov 2011
    Link to this post
    Hi Boyan,

    thank you for your reply. I have followed your instructions and I am still having issues with the "Master" control acting oddly. It typically will show list with only the item that should show on the detail view and on a couple items it will show 2 news items.

    http://www.pmcworld.com/who-we-are/news/item/2011/11/14/grow-southern-california-operations
    you will see the Master is in the footer of the page called "Announcements".

    thanks for your help.
  4. Boyan Barnev
    Boyan Barnev avatar
    1429 posts
    Registered:
    30 Oct 2017
    22 Nov 2011
    Link to this post
    Hi Sacparker,

    Can you please go to the master widget's settings - > Advanced ->ControlDefinition->Views-> Master and set the AllowUrlQueries to false, and let us know if any problems persist.

    Best wishes,
    Boyan Barnev
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
4 posts, 0 answered