More in this section

Forums / Developing with Sitefinity / Internet Explorer And Sitefinity

Internet Explorer And Sitefinity

8 posts, 1 answered
  1. Matthew
    Matthew avatar
    28 posts
    Registered:
    07 Mar 2011
    24 Nov 2011
    Link to this post
    Hi Support,

    We have a local intranet site (currently for dev purposes) and we are trying to take advantage of HTML5 and CSS3 however when previewing the site in IE9 either like so http://WebDev/Website (over the network) or http://localhost/Website (on the local webserver) IE developer tools tell us that the page deault is IE8 standards.

    We have added a response header in IIS (Name: X-UA-Compatible Value:IE=Edge) and we have unchcked the display intranet sites in compatibility view checkbox in IE.

    Basicaly I was just wondering if sitefinity somehow overrides this or if there is a setting in Sitefinity I need to change

    Thanks in advance

    Dan

  2. Tim
    Tim avatar
    258 posts
    Registered:
    22 Jun 2011
    28 Nov 2011
    Link to this post
    Daniel,

    If you haven't already solved the issue, check this out. If you have the ability to modify the headers coming from IIS, I would handle it via web.config.

    Also, since you're getting into HTML5, you should give html5 boilerplate a look.

    Good luck!
  3. Matthew
    Matthew avatar
    28 posts
    Registered:
    07 Mar 2011
    28 Nov 2011
    Link to this post
    Hi Tim,

    Thanks for your links they were very useful.

    I think however I may not have explained the problem correctly.

    I have a site in siteifinity making use of HTML 5 and CSS 3 for this I need Internet Explorer 9 so I have set the x-ua compatable tag in the web config to IE=Edge (I heard that this means that the site should use internet explorers default rendering engine not the compatibility view version).

    After adding this tag to the web.config file I noticed that IE was still saying that IE8 was the page standard (I did restart IIS and clear my cache but this had no affect).

    After a little bit more digging I found that IE has a check box to display all intranet sites in compatibility view so I unchecked this and the site is still using IE 8 as a default setting.

    hopefully that clears things up a little bit

    Thanks again for your response.

    Dan
  4. Tim
    Tim avatar
    258 posts
    Registered:
    22 Jun 2011
    28 Nov 2011
    Link to this post
    Daniel,

    I get what you're trying to do, just not why it's not working :)

    <meta http-equiv="X-UA-Compatible" content="IE=edge" />

    That should take care of it, if added to the page.

    <configuration>
      <system.webServer>
         <httpProtocol>
            <customHeaders>
               <add name="X-UA-Compatible" value="IE=Edge" />
            </customHeaders>
         </httpProtocol>
      </system.webServer>
    </configuration>

    That should send the magic header out from IIS.

    <!doctype html>

    Just for completeness, the doctype declaration.

    If you're still handling it via web config, can you verify that the header is being sent? Firebug is pretty good for that sort of thing.

  5. Matthew
    Matthew avatar
    28 posts
    Registered:
    07 Mar 2011
    28 Nov 2011
    Link to this post
    Hi Tim,

    Ok so this is what I have:

    X-UA-Compatible = IE=Edge as a HTTP Response Header

    In The web config I have the following ( I am guessing form when I added the Response header!)

      <httpProtocol>
        <customHeaders>
          <add name="X-UA-Compatible" value="IE=Edge"/>
        </customHeaders>
      </httpProtocol>

    And on the page once it has been rendered we have the following (source taken form FF not that, that should make a difference ;-))

    <meta http-equiv="X-UA-Compatible" content="IE=8" />

    My doctype is transitional - which I am now guessing could be an issue as HTML 5 has no references to DTD's.

    Can I change a sitefinity template doc type or will I have to upload a master page to do this?

    Thanks for you help with this

    Dan
  6. Tim
    Tim avatar
    258 posts
    Registered:
    22 Jun 2011
    28 Nov 2011
    Link to this post
    Daniel,

    If the header is coming through from IIS, you can remove the X-UA-Compatible tag from the source. Also, you'll definitely need the correct doctype to be present.

    Using a custom master page would help you and this thread has a working example to get you started. It includes a reference to Modernizr which is a useful tool for checking browser capabilities.

    HTML5 is a good thing. It's worth every single step to get it working for you! :)
    Answered
  7. Matthew
    Matthew avatar
    28 posts
    Registered:
    07 Mar 2011
    28 Nov 2011
    Link to this post
    Hi tim,

    Thats Great thanks for your help with this it is greatly appreciated.

    Thanks again

    Dan
  8. Matthew
    Matthew avatar
    28 posts
    Registered:
    07 Mar 2011
    29 Nov 2011
    Link to this post
    Hi tim (and anyone else reading this post!)

    Just to let you know it does appear that the doc type declaration is what was throwing it out of HTML5 mode and in turn making IE render in compatibility mode.

    Thanks agian for you help

    Dan
8 posts, 1 answered