More in this section

Forums / Developing with Sitefinity / Issue with radmenu

Issue with radmenu

5 posts, 0 answered
  1. Surya CD
    Surya CD avatar
    57 posts
    Registered:
    06 Apr 2010
    16 Jun 2012
    Link to this post
    Hi,
    I am migrating a website from SF 3.7 to 5. The site is deployed in azure.
    Everything was working fine. But now the site is showing error when I try to edit the page in admin site.
    Value cannot be null.
    Parameter name: key.
    When I check the template for the master page, it shows this error message in the widget area of menu controls.


    What is causing this error. Please help. 
    Is it related to radcontrol because both these are radcontrols. Or is it related to the BuildAction property. If so, what should be set to this property.


    Thanks.
  2. MB
    MB avatar
    302 posts
    Registered:
    09 Jan 2005
    16 Jun 2012
    Link to this post
    At a guess, your logic assumes a reference that does not exist when editing a page/template.

    You probably need to breakpoint it with Visual Studio and find the offending reference, and perhaps conditionalize it for admin/edit circumstances.

    Do a search on how to tell if you are in admin/edit mode.
  3. Surya CD
    Surya CD avatar
    57 posts
    Registered:
    06 Apr 2010
    18 Jun 2012
    Link to this post


  4. Surya CD
    Surya CD avatar
    57 posts
    Registered:
    06 Apr 2010
    20 Jun 2012
    Link to this post
    Hi,
    The issue occurs for only a few pages. For the remaining pages, there is no error when opened in edit mode. Also, when the error occurs the site is sometimes available in another browser, sometimes it is not. 
    Please help.
  5. Surya CD
    Surya CD avatar
    57 posts
    Registered:
    06 Apr 2010
    27 Jun 2012
    Link to this post
    Can anyone please help me with this
5 posts, 0 answered