More in this section
Forums / Developing with Sitefinity / My Image Doesnt Appear in the SitefinityLabel (Cssed sfitemRichText)

My Image Doesnt Appear in the SitefinityLabel (Cssed sfitemRichText)

The forums are in read-only mode. In case that you want to directly contact the Progress Sitefinity team use the support center. In our Google Plus group you can find more than one thousand Sitefinity developers discussing different topics. For the Stack Overflow threads don’t forget to use the “Sitefinity” tag.
1 posts, 0 answered
  1. xman
    xman avatar
    4 posts
    Registered:
    07 Mar 2016
    03 Apr 2017
    Link to this post

    Hi everyone

    I have create Dynamic content which has a LongText field for containing my richtext text, and I want to display the richtext that contains an image by my own custom .ascx widget

    I run the page that contain .ascx widget to display my richtext with my image from my library, the text formatted correctly, but the image doesnt appear properly(only alt text).

    So I checked the image source and i found the sfref="[images|OpenAccessDataProvider|tmb:small]...."
    and i decided to delete the sfref, and the image showed correctly

    But it is impossible to ask the user to delete the sfref in the HTML source each time the user create a content that use an image

    How to make the <sf:SitefinityLabel tag shows image correctly, without change the image source manually(delete sfref in the image tag) if the content has images

    I use this tag to display richtext:

    <sf:SitefinityLabel ID="lblRichText" runat="server" Text='' WrapperTagName="div" HideIfNoText="true" CssClass="sfitemRichText" data-sf-field="content" data-sf-ftype="LongText"/>

     

    Thanks

1 posts, 0 answered