More in this section
Forums / Developing with Sitefinity / OA Version Compile Errors

OA Version Compile Errors

The forums are in read-only mode. In case that you want to directly contact the Progress Sitefinity team use the support center. In our Google Plus group you can find more than one thousand Sitefinity developers discussing different topics. For the Stack Overflow threads don’t forget to use the “Sitefinity” tag.
2 posts, 0 answered
  1. Steve
    Steve avatar
    3037 posts
    03 Dec 2008
    06 Dec 2011
    Link to this post
    We have an OA Assembly in the solution that references OA Q3 2011 (2011.3.1116.3), but the 4.3 version in the SF project is 2011.2.713.3.

    This is the first time I've seen compile errors when building, usually it seems to build, but assembly binding is required to get the front-end to load.

    Is there any way to get these to play happily?
  2. Lubomir Velkov
    Lubomir Velkov avatar
    688 posts
    03 Nov 2014
    09 Dec 2011
    Link to this post
    Hi Steve,

    Unfortunately there isn't a way to use a different version of OA in a Sitefinity project. The version of OA that comes with the Sitefinity version is the version you can use and there is not a way to change this, even with assembly redirection.

    Best wishes,
    Lubomir Velkov
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
2 posts, 0 answered