More in this section

Forums / Developing with Sitefinity / [sitefinity 4.4] smtp configuration

[sitefinity 4.4] smtp configuration

5 posts, 0 answered
  1. Elsane
    Elsane avatar
    30 posts
    Registered:
    06 Jan 2012
    30 Apr 2012
    Link to this post
    Hello,

    I have a litle problem with the smtp configuration : it seems the domain name I enter in the smtpDomain of the smtp Settings panel is not used when I tried to send an email.

    The smtp server answer "Helo command rejected: need fully-qualified hostname". I tried to send an email by telnet, all work fine.

    I asked the log of the smtp server and it seems Sitefinity send the IP of the server in place of the domain I set up.

    Here the line of the systemConfig.config file :

    <smtpSettings host="mysmtp.server" domain="my.domain" DefaultSenderEmailAddress="info@my.domain" />

    I tried to send an email programatically : same error...

    Any idea ?

    thank you
  2. SelAromDotNet
    SelAromDotNet avatar
    912 posts
    Registered:
    18 Jul 2012
    30 Apr 2012
    Link to this post
    Are you attempting to send an email using the Email Campaigns module? If so, this module has a separate set of SMTP settings that must also be configured (even if they match the ones you've already set in System config).

    For more information on setting up both SMTP settings, see this guide: Set up SMTP & Email campaigns settings

    Hope this is helpful, please let me know if this doesn't resolve your issue
  3. Elsane
    Elsane avatar
    30 posts
    Registered:
    06 Jan 2012
    02 May 2012
    Link to this post
    Hello,

    We are trying to setup smtp for the registration widget. But as it doesn't work we configure smtp for email campaign folowing the instruction you give.
    In Administration > Settings > Email campaign
    when we save the data we have this message that shows up  in sitefinity backoffice:

    "Helo command rejected: need fully-qualified hostname".

    When we try to connect to the smtp server via telenet using the same info it works well.

    Contacting our smtp provider they tell us that our application is sending the IP of the machine and not its hostname. That's why the connection is rejected. How can we configure sitefinity to send the machine domain and not the IP ?

    (we have a standard license activated for the domain)

    Thanks.
  4. Elsane
    Elsane avatar
    30 posts
    Registered:
    06 Jan 2012
    02 May 2012
    Link to this post
    <mailSettings>
            <smtp deliveryMethod="network">
              <network clientDomain="FQDN"/>
            </smtp>
    </mailSettings>
    Well, I resolved my problem.

    Actually, it seems Sitefinity was not the cause. As explained above the client hostname sent in parameter of the HELO command was invalid.

    I found a fix in adding to my webconfig file.

    Anyway thank for your answer. A question still remains, why an option Domain in the smtp setting of the admin page if it's not in use ?
  5. SelAromDotNet
    SelAromDotNet avatar
    912 posts
    Registered:
    18 Jul 2012
    02 May 2012
    Link to this post
    I apologize for misunderstanding your original question. I'll forward this to the team for investigation to see if it is something that needs to be fixed.

    I'm glad you did get it working and thank you kindly for reporting this issue!
5 posts, 0 answered