More in this section

Forums / Developing with Sitefinity / strange url in localhost after updating to claims-based authentication

strange url in localhost after updating to claims-based authentication

4 posts, 0 answered
  1. Robert
    Robert avatar
    17 posts
    30 Aug 2011
    09 Oct 2012
    Link to this post
    After I updated my Sitefinity project to claims-based authentication, when I run it in debug mode from visual studio on localhost, I get a strange guid-type string in my urls that prefixes the site root, for example:
    for the CMS backend.  I am also getting strange 12030 errors when I do things like modify a page, and the logs tell me that sitefinity can't find the file, eg:
    10/08/2012 08:39:06
    Type : System.Web.HttpException, System.Web, Version=, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a
    Message : File does not exist.
    Source : System.Web
    Help link :
    WebEventCode : 0
    ErrorCode : -2147467259
    Data : System.Collections.ListDictionaryInternal
    TargetSite : Boolean ProcessRequestForNonMapPathBasedVirtualFile(System.Web.HttpRequest, System.Web.HttpResponse, System.String)
    Stack Trace :    at System.Web.StaticFileHandler.ProcessRequestForNonMapPathBasedVirtualFile(HttpRequest request, HttpResponse response, String overrideVirtualPath)
       at System.Web.StaticFileHandler.ProcessRequestInternal(HttpContext context, String overrideVirtualPath)
       at System.Web.DefaultHttpHandler.BeginProcessRequest(HttpContext context, AsyncCallback callback, Object state)
       at System.Web.HttpApplication.CallHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute()
       at System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously)

    I think these two problems are related, but has anyone else experienced something like this?  Do you know how to get rid of the guid - structures in the url?

  2. Robert
    Robert avatar
    17 posts
    30 Aug 2011
    10 Oct 2012
    Link to this post
    I found the solution, which was in my web.config
    I copied down some settings from a site that worked and one of these settings was under System.Webserver:

    (add the xml < and /> tags which seem to cause an internal error on this forum)

    urlCompression doDynamicCompression="true" doStaticCompression="true" dynamicCompressionBeforeCache="false"

    Hope it is of use to someone else
  3. Robert
    Robert avatar
    17 posts
    30 Aug 2011
    03 Apr 2013 in reply to Robert
    Link to this post
    Update:  It seems this was in fact caused by sessionState cookieless="true" in the web.config.  Removing it from the config file if it exists or changing the
    attribute value from “true” to “false” will sort out the issue. Setting the
    value to “true” means the ASP.Net has to figure out a way to keep track of the
    session state and it chooses to do this by saving a unique id within the URL of
    the website.

  4. Stefani Tacheva
    Stefani Tacheva avatar
    718 posts
    31 May 2017
    08 Apr 2013
    Link to this post

    I am glad to hear the you have managed to find what is causing the problem and thank you for sharing this information with the community.

    Stefani Tacheva
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
4 posts, 0 answered