More in this section

Forums / Developing with Sitefinity / Widget Templates Gone

Widget Templates Gone

7 posts, 0 answered
  1. Victor
    Victor avatar
    94 posts
    Registered:
    15 Jun 2011
    20 Dec 2011
    Link to this post
    After upgrading from SF 4.0 to 4.3, some of our page templates were corrupted.  We were able to make changes to them and get them fixed, but our widget templates are gone.  Using firebug,  it looks like the service call below errors out, but no error message is shown.  And there's no entry in the error log.

    http://xx.xx.xx.xxx/Sitefinity/Services/ControlTemplates/ControlTemplateService.svc/?managerType=&providerName=&itemType=Telerik.Sitefinity.Pages.Model.PresentationData&provider=&sortExpression=DateCreated%20DESC&skip=0&take=50

    Are ideas?
  2. Boyko Karadzhov
    Boyko Karadzhov avatar
    56 posts
    Registered:
    05 Dec 2016
    22 Dec 2011
    Link to this post
    Hi,

    We do not support a direct upgrade from 4.0 to 4.3. You should upgrade sequentially from 4.0 to 4.1, 4.2 and finally to 4.3.

    Kind regards,
    Boyko Karadzhov
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. Victor
    Victor avatar
    94 posts
    Registered:
    15 Jun 2011
    06 Jan 2012
    Link to this post
    I've now sequentially upgraded and still get the same error.  Any ideas?
  4. Boyko Karadzhov
    Boyko Karadzhov avatar
    56 posts
    Registered:
    05 Dec 2016
    10 Jan 2012
    Link to this post
    Hello,

     This is not a normal behavior and I don't know how it can be reproduced. You can post a support ticket and upload the database and the project files so we can inspect this issue at our end in more detail.

    Greetings,
    Boyko Karadzhov
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  5. Moiz Ahmed
    Moiz Ahmed avatar
    7 posts
    Registered:
    07 Oct 2012
    10 Feb 2012
    Link to this post
    Hi,
    Is this some sort of a problem with sitefinity 4.3, I too seem to have lost the default templates from the sitefinity interface. I even tried accessing the url directly to see what it returns 
    http://192.168.1.102:1240/Sitefinity/Services/ControlTemplates/ControlTemplateService.svc/?managerType=&providerName=&itemType=Telerik.Sitefinity.Pages.Model.PresentationData&provider=&sortExpression=DateCreated%20DESC&skip=0&take=50&filter=

    but the result is This webpage is not available

  6. Boyko Karadzhov
    Boyko Karadzhov avatar
    56 posts
    Registered:
    05 Dec 2016
    16 Feb 2012
    Link to this post
    Hi,

     No, this is not a known issue or a reported bug. Could you describe how to reproduce the problem?

    All the best,
    Boyko Karadzhov
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  7. Moiz Ahmed
    Moiz Ahmed avatar
    7 posts
    Registered:
    07 Oct 2012
    18 Feb 2012
    Link to this post
    Hi Boyko,

    I tried making another project installing all the modules and possibly reproducing almost every step in a new project but didn't get an error this time.

    This may have happened at the time when I switched the licence from standard to professional, because this is the only step that I didn't perform in this project. 

    Thanks,
    Moiz Ahmed Sulaiman
7 posts, 0 answered