More in this section

Forums / Developing with Sitefinity / 2 reply buttons on forum

2 reply buttons on forum

4 posts, 0 answered
  1. Troy Lawrence
    Troy Lawrence avatar
    56 posts
    Registered:
    07 Jan 2010
    24 May 2010
    Link to this post
    I am seeing 1 reply buttons on my forum post pages.  I'm not sure why?  I've attached a screen shot for clarity.
  2. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    12 Sep 2017
    24 May 2010
    Link to this post
    Hello Troy Lawrence,

    As far as I see it you use some custom template. You should better observe the template you have customized. If you cannot sort our the issue you could paste the template here using FormatCodeBlock option of the RadEditor control.

    All the best,
    Ivan Dimitrov
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
  3. Troy Lawrence
    Troy Lawrence avatar
    56 posts
    Registered:
    07 Jan 2010
    24 May 2010
    Link to this post
    <%@ Register TagPrefix="sfMsg" Namespace="Telerik.Cms.Web.UI" Assembly="Telerik.Cms.Web.UI" %>
    <%@ Register Assembly="Telerik.Cms.Web.UI" Namespace="Telerik.Cms.Web.UI" TagPrefix="sfWeb" %>
    <%@ Register Assembly="Telerik.Security" Namespace="Telerik.Security.WebControls" TagPrefix="prof" %>
    <%@ Register Assembly="Telerik.Cms.Web.UI" Namespace="Telerik.Cms.Web.UI" TagPrefix="sfWeb" %>
     
    <sfWeb:CssFileLink ID="CssFileLink1" FileName="~/Sitefinity/ControlTemplates/Forums/forumsCommonLayout.css" Media="screen" runat="server" />
     
    <div class="sf_forumsWrapper">
    <p class="sf_back"><asp:LinkButton ID="backToThreadsButton" runat="server" CausesValidation="false" Text="<%$Resources:ToAllThreads %>"></asp:LinkButton></p>
    <sfMsg:MessageControl runat="server" ID="messageControl">
        <ItemTemplate>
            <asp:Label runat="server" ID="messageText"></asp:Label>
        </ItemTemplate>
    </sfMsg:MessageControl>
        <div class="sf_threadTitle">
            <h1><asp:Literal runat="server" ID="threadTitle"></asp:Literal></h1>
            <asp:LinkButton ID="deleteThreadButton" runat="server" Text="<%$Resources:DeleteThread %>"></asp:LinkButton>
        </div>
    <p class="sf_createNewItem"><asp:LinkButton ID="postReplyButton1" runat="server" Text="<%$Resources:PostReply %>" CssClass="CmsButLeft new"></asp:LinkButton></p>
     
    <dl class="sf_userInfo">
        <dt>
        <prof:ManageProfile ID="userProfile" runat="server">
            <ViewTemplate>
                <asp:Literal ID="FirstName" runat="server"></asp:Literal
                <asp:Literal ID="LastName" runat="Server"></asp:Literal>
     
            </ViewTemplate>
        </prof:ManageProfile>
        </dt>
        <dt><asp:Label ID="anonymousName" runat="server" Text="Anonymous"></asp:Label></dt>
        <dd><asp:Literal ID="authorRole" runat="server"></asp:Literal></dd>
        <dd class="sf_postsCount">
            (<asp:Literal ID="authorPostCount" runat="server"></asp:Literal><asp:Literal runat="server" ID="postCountText" Text="<%$Resources:Posts %>"></asp:Literal>)
        </dd>
    </dl>
    <div class="sf_postContent">
        <p class="sf_forumDate"><sfWeb:DateTimeLiteral runat="server" ID="threadDate" DateFormatString="dd MMM yyyy, hh:mm" /></p>
        <div><asp:Literal ID="threadContent" runat="server"></asp:Literal></div>
    </div>
    <p class="sf_postCommands">
        <div class="forumButtons"
        <asp:LinkButton ID="editThreadButton" runat="server" Text=""><span>Edit</span></asp:LinkButton><div class="forumButtonsSpacer"></div>
        <asp:LinkButton ID="replyToThread" runat="server" Text=""><span>Reply</span></asp:LinkButton>
        </div
     
    </p>   
    <asp:Repeater ID="allPosts" runat="server">
        <ItemTemplate>
            <dl class="sf_userInfo">
                <dt>
                <prof:ManageProfile ID="userProfile" runat="server">
                    <ViewTemplate>
                        <asp:Literal ID="FirstName" runat="server"></asp:Literal
                        <asp:Literal ID="LastName" runat="Server"></asp:Literal>
                    </ViewTemplate>
                </prof:ManageProfile>
                </dt>
                <dt><asp:Label ID="anonymousName" runat="server" Text="Anonymous"></asp:Label></dt>
                <dd><asp:Literal ID="authorRole2" runat="server"></asp:Literal></dd>
                <dd class="sf_postsCount">
                    (<asp:Literal ID="authorPostCount2" runat="server"></asp:Literal><asp:Literal runat="server" ID="postCountText2" Text="<%$Resources:Posts %>"></asp:Literal>)
                </dd>
            </dl>
            <div class="sf_postContent">
                <p class="sf_forumDate"><sfWeb:DateTimeLiteral runat="server" ID="postDate" DateFormatString="dd MMM yyyy, hh:mm" /></p>
                <p><asp:Literal ID="postContent" runat="server"></asp:Literal></p>
            </div>       
            <p class="sf_postCommands">
            <div class="forumButtons"
                <asp:LinkButton ID="btnEdit" runat="server" CommandName="EditPost" Text=""><span>Edit</span></asp:LinkButton><div class="forumButtonsSpacer"></div>
                <asp:LinkButton ID="btnDelete" runat="server" CommandName="DeletePost" Text=""><span>Delete</span></asp:LinkButton><div class="forumButtonsSpacer"></div>
                <asp:LinkButton ID="btnReply" runat="server" CommandName="ReplyToPost" Text=""><span>Reply</span></asp:LinkButton>
                </div>
            </p>
        </ItemTemplate>
    </asp:Repeater>
    <%--<p class="sf_createNewItem">
    <div class="forumButtons">
    <asp:LinkButton ID="postReplyButton2" runat="server" Text=""><span>Reply</span></asp:LinkButton>
    </div>
     
    </p>--%>
    </div>
  4. Radoslav Georgiev
    Radoslav Georgiev avatar
    3370 posts
    Registered:
    01 Feb 2016
    25 May 2010
    Link to this post
    Hello Troy Lawrence,

    The second reply button is appearing because you are missing some style rules to alling it.  Also it should say Post Reply. If you use the provided styles the buttons and not wrap it in div with id forumButtons it will appear on the bottom of the thread in the left hand corner. The original markup for this button is:
    <p class="sf_createNewItem"><asp:LinkButton ID="postReplyButton2" runat="server" Text="<%$Resources:PostReply %>"></asp:LinkButton></p>


    Greetings,
    Radoslav Georgiev
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
Register for webinar
4 posts, 0 answered