More in this section

Forums / Developing with Sitefinity / News List control

News List control

6 posts, 0 answered
  1. Annie
    Annie avatar
    46 posts
    Registered:
    11 Aug 2012
    30 Nov 2009
    Link to this post
    Hi,

    When we add the news list control to a page, the link on the news control page is pointing to the wrong URL. How can I fix this

    Thanks,
    Annie
  2. Radoslav Georgiev
    Radoslav Georgiev avatar
    3370 posts
    Registered:
    01 Feb 2016
    01 Dec 2009
    Link to this post
    Hello Annie,

    Thank you for using our services.

    When you set up the News View control do you set it up to auto generate the details page for single news, or you want it to point to a specially created single news item page. If the second case, please see attached images on how to configure the news view controls on the list page and details page (news view control is required on the details page).

    Greetings,
    Radoslav Georgiev
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
  3. Annie
    Annie avatar
    46 posts
    Registered:
    11 Aug 2012
    01 Dec 2009
    Link to this post
    Hi,

    We have set up the news page to auto generate the details page for single news

    Thanks,
    Annie
  4. Radoslav Georgiev
    Radoslav Georgiev avatar
    3370 posts
    Registered:
    01 Feb 2016
    01 Dec 2009
    Link to this post
    Hi Annie,

    Thank you for getting back to me.

    Could you please explain the issue in more detail, a couple of screen shots portraying the issue would be also helpful?

    Regards,
    Radoslav Georgiev
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
  5. Annie
    Annie avatar
    46 posts
    Registered:
    11 Aug 2012
    01 Dec 2009
    Link to this post
    Hi,

    I have attached the screen shots for the problem, first screen shot newsitem.jpg shows the news item when we click on the full story link as shown in the screenshot we get a server error in application (page cannot be found) as shown in the second screen shot

    Thanks,
    Annie
  6. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    12 Sep 2017
    01 Dec 2009
    Link to this post
    Hello Annie,

    I tested with several news items, but I am not able to reproduce the problem you have. Can you reproduce it on our demo website and give is the steps? Try using a newly dropped control on a page.

    Kind regards,
    Ivan Dimitrov
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
Register for webinar
6 posts, 0 answered