More in this section

Forums / Developing with Sitefinity / Added ASP.NET control to template and crashed.

Added ASP.NET control to template and crashed.

6 posts, 0 answered
  1. David Belcher
    David Belcher avatar
    5 posts
    Registered:
    03 May 2008
    29 May 2008
    Link to this post

    Configuration Error

    Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

    Parser Error Message: Could not load file or assembly 'Telerik.Framework' or one of its dependencies. The system cannot find the file specified.

    Source Error:

    Line 125:      </eventMappings>
    Line 126: <providers>
    Line 127: <add name="Simple Web Event Provider" type="Telerik.Utilities.TextFileWebEventProvider,Telerik.Framework" logFileName="~/App_Data/sitefinity.log" />
    Line 128: <add name="Simple Web Buffered Event Provider" type="Telerik.Utilities.BufferedTextFileWebEventProvider,Telerik.Framework" bufferMode="Notification" logFileName="~/App_Data/sitefinity.log" />
    Line 129: <add name="Code Benchmark Provider" type="Telerik.Utilities.CodeBenchmarkTextFileProvider,Telerik.Framework" enabled="False" logFileName="~/App_Data/performance.log" />

    Source File: D:\Telerik\Sitefinity3.2 Community\WebSites\Asbury-UMCsmfld\web.config    Line: 127

    Assembly Load Trace: The following information can be helpful to determine why the assembly 'Telerik.Framework' could not be loaded.

    WRN: Assembly binding logging is turned OFF.
    To enable assembly bind failure logging, set the registry value [HKLM\Software\Microsoft\Fusion!EnableLog] (DWORD) to 1.
    Note: There is some performance penalty associated with assembly bind failure logging.
    To turn this feature off, remove the registry value [HKLM\Software\Microsoft\Fusion!EnableLog].


    Version Information: Microsoft .NET Framework Version:2.0.50727.1434; ASP.NET Version:2.0.50727.1434

    All I did was add a ASP.NET control to the .master uploaded it fine then went to preview site and got the above.

    Thanks
    Dave
  2. David Belcher
    David Belcher avatar
    5 posts
    Registered:
    03 May 2008
    29 May 2008
    Link to this post
    This is the code I added via VS2008:

    <div id="Footer" align="center">
                <cc1:CopyRightControl ID="CopyRightControl1" runat="server"
                    Company="H.M.J. Arnoldus                            "             />
                    </div>
           </div>
                <p align="center">
                <cc1:LastUpdateControl ID="LastUpdateControl1" runat="server" />
                    </p>

    The CopyRightControl and the LastUpdateControl are third party.

    Is this not allowed in Sitefinity?
  3. Pepi
    Pepi avatar
    981 posts
    Registered:
    31 Jan 2017
    29 May 2008
    Link to this post
    Hi David,

    It should not be a problem to use third party controls within Sitefinity. Could you reproduce the same issue if you remove the controls from the master page? Do you use a Standard or a Community edition?

    Also
    , check if you have Telerik.Framework.dll assembly in the ~/bin folder of your project.

    If everything is properly set and you are sure that the reason for the error is adding the controls, send us the third party .dll to debug the issue locally.

    Thanks for your cooperation in advance.

    Kind regards,
    Pepi
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
  4. David Belcher
    David Belcher avatar
    5 posts
    Registered:
    03 May 2008
    30 May 2008
    Link to this post
    I think everything it set properly. Now getting this:

    Parser Error

    Description: An error occurred during the parsing of a resource required to service this request. Please review the following specific parse error details and modify your source file appropriately.

    Parser Error Message: Could not load file or assembly 'WebControlLibrary1' or one of its dependencies. The system cannot find the file specified.

    Source Error:

    Line 1:  <%@ Master Language="C#" %>
    Line 2:  
    Line 3:  <%@ Register assembly="WebControlLibrary1" namespace="WebControlLibrary1" tagprefix="cc1" %>
    Line 4:  
    Line 5:  <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">

    Source File: /asbury-umcsmfld-community/App_Master/Default (1).master    Line: 3

    Assembly Load Trace: The following information can be helpful to determine why the assembly 'WebControlLibrary1' could not be loaded.

    WRN: Assembly binding logging is turned OFF.
    To enable assembly bind failure logging, set the registry value [HKLM\Software\Microsoft\Fusion!EnableLog] (DWORD) to 1.
    Note: There is some performance penalty associated with assembly bind failure logging.
    To turn this feature off, remove the registry value [HKLM\Software\Microsoft\Fusion!EnableLog].
    

    It has to be the control. If taken out works fine.
    Using the default.master of the community template in community edition.

    Please let me know where to send the dll.

    Thank-you
  5. Pepi
    Pepi avatar
    981 posts
    Registered:
    31 Jan 2017
    30 May 2008
    Link to this post
    Hi David,

    First of all, check if you have registered the custom control correctly:
    1. Make sure that the name of the assembly is WebControlLibrary1. You should have WebControlLibrary1.dll in the ~/bin folder of the project.
    2. Make sure that the name of the namespace is WebControlLibrary1.

    As for sending the third party control, you need to archive the .dll, open a new support ticket and attach the zip.

    Greetings,
    Pepi
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
  6. David Belcher
    David Belcher avatar
    5 posts
    Registered:
    03 May 2008
    30 May 2008
    Link to this post
    Pepi:

    I have know idea what I did, but things are working great now.

    Thanks for the help
Register for webinar
6 posts, 0 answered