More in this section

Forums / Developing with Sitefinity / added .sflb and .tmb , images still won't display

added .sflb and .tmb , images still won't display

5 posts, 0 answered
  1. Ali
    Ali avatar
    37 posts
    Registered:
    11 Jun 2008
    29 Oct 2008
    Link to this post
    I have tried clearing my cache, waited about 30min for my hosting server to update (I am on a shared server through hostmysite.com)

    I still can't see the images. All of them were uploaded after the iis extensions were added. I also have the correct information in my web.config

    <httpHandlers> 
          <add verb="*" path="Telerik.RadUploadProgressHandler.ashx" type="Telerik.Web.UI.Upload.RadUploadProgressHandler, Telerik.Web.UI"/> 
          <add verb="*" path="*.rss" type="Telerik.Rss.RssHttpHandler, Telerik.Rss"/> 
          <add verb="GET" path="*.sflb" type="Telerik.Cms.Engine.ContentHttpHandler, Telerik.Cms.Engine"/> 
          <add verb="GET" path="*.tmb" type="Telerik.Cms.Engine.ContentHttpHandler, Telerik.Cms.Engine"/> 
          <add verb="*" validate="false" path="Telerik.Web.UI.DialogHandler.aspx" type="Telerik.Web.UI.DialogHandler, Telerik.Web.UI"/> 
          <add verb="*" validate="false" path="Telerik.Web.UI.SpellCheckHandler.axd" type="Telerik.Web.UI.SpellCheckHandler, Telerik.Web.UI"/> 
          <add verb="*" validate="false" path="ChartImage.axd" type="Telerik.Web.UI.ChartHttpHandler, Telerik.Web.UI"/> 
          <remove verb="*" path="*.asmx"/> 
          <add verb="*" path="*.asmx" validate="false" type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/> 
          <add verb="*" path="*_AppService.axd" validate="false" type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/> 
          <add verb="GET,HEAD" path="ScriptResource.axd" type="System.Web.Handlers.ScriptResourceHandler, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" validate="false"/> 
          <add verb="GET" path="CaptchaImage.axd" type="Telerik.Web.UI.SpamProtection.Captcha.CaptchaImageHandler, Telerik.Cms.Web.UI"/> 
          <add verb="POST" path="blogs/metablog.ashx" type="Telerik.Blogs.MetaWeblog.MetaWeblogHandler, Telerik.Blogs"/> 
          <add verb="POST" path="trackback.ashx" type="Telerik.Cms.Engine.Trackback.TrackbackHandler, Telerik.Cms.Engine"/> 
        </httpHandlers> 

    I don't know what else to do. did I miss something else? here is the page I created www.sacucca.org/photogallery.aspx Any info would be greatly appreciated. Thanks!
  2. Joe
    Joe avatar
    138 posts
    Registered:
    24 Sep 2012
    29 Oct 2008
    Link to this post
    Hello Ali,

    Thanks for contacting us.

    Have you mapped the .tmb, .sflb, .rss, and .template mappings to IIS? As of version 3.5, we used .asmx handlers for the images and documents module, which means that these handlers no longer need to be applied to IIS manually.Since you are using an older version of Sitefinity, I would advise you to upgrade to our 3.5 SP 1 release, which was released today, and let us know if the images still don't show.

    I hope that this solves your technical issue. Please write back if you need further assistance.

    Regards,
    Joe
    the Telerik team

    Check out Telerik Trainer, the state of the art learning tool for Telerik products.
  3. Ali
    Ali avatar
    37 posts
    Registered:
    11 Jun 2008
    29 Oct 2008
    Link to this post
    I used the blank project to create my site, do I just download the same blank project and copy over all the files? I read how to and was a little confused what you were referring to in the documentation where it says "Patch" .

    which "Patch" should I use and where can I download it from? I apologize for my ignorance.
  4. Ali
    Ali avatar
    37 posts
    Registered:
    11 Jun 2008
    29 Oct 2008
    Link to this post
    Unfortunately I pay for hosting and am on a shared server so I don't have access to my IIS. Is there a way to test if my hosting company set up the extensions correctly?
  5. Joe
    Joe avatar
    138 posts
    Registered:
    24 Sep 2012
    29 Oct 2008
    Link to this post
    Hello Ali,

    Thanks for the follow up.

    Some hosting companies don't allow their customers to touch IIS on their plan, especially with Shared Hosting, so I would recommend the upgrade. To download the hotfix (aka patch) follow these instructions:

    1. Login to your Client.net account
    2. Click on downloads
    3. Click on this file name: Sitefinity_3_5_1747_community_patch.zip (since you are using the Community Edition)

    All the best,
    Joe
    the Telerik team

    Check out Telerik Trainer, the state of the art learning tool for Telerik products.
Register for webinar
5 posts, 0 answered