More in this section

Forums / Developing with Sitefinity / Bug in categorieslist?

Bug in categorieslist?

3 posts, 0 answered
  1. wouter bos
    wouter bos avatar
    4 posts
    Registered:
    29 Jul 2009
    01 Sep 2009
    Link to this post
    hi,

    I'm using sitefinity 3.7. I wanted to use the categorieslist to show the categories of one library collection, but it consistently sais that there are 5 items in the category items. The categoriestree on the other hand does display the right number. I read somewhere that the categorieslist is obsolete, but I can't seem to make the categoriestree behave like the categorieslist. The following code just gives javascript errors when I want to disable it.


    <telerik:RadTreeView ID="categoriesTreeView" runat="server" EnableEmbeddedBaseStylesheet="false" EnableAjaxSkinRendering="false" EnableDragAndDrop="false" EnableEmbeddedScripts="false">
    </telerik:RadTreeView>
  2. Nikolai
    Nikolai avatar
    216 posts
    Registered:
    01 Jun 2017
    01 Sep 2009
    Link to this post
    Hello wouter bos,

    Basically you can use the CategoryTree to display the top level categories by setting the MaxDataBindDepth
    to "0". The difference between CategoryTree and CategoryList is that the list shows only the top level categories and their count is the sum of their children's count.


    Kind regards,
    Nikolai
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
  3. wouter bos
    wouter bos avatar
    4 posts
    Registered:
    29 Jul 2009
    01 Sep 2009
    Link to this post
    Hi,

    Thank you for your reply. I know that both controls should look the same, but I couldn't configure it that way without bugs. My (and other problems) seemed to stem from the fact that I upgraded a 3.6 website to 3.7. I discovered that when the page of the newsletter module failed to load. I copied all kind of files from a 'real' 3.7-website and after copying a bunch of directories in the ~/Sitefinity-folder all my troubles disappeared.

    thanks again!

    wouter
Register for webinar
3 posts, 0 answered