More in this section

Forums / Developing with Sitefinity / Call editmode for item in a library loses original values / Saving values of new Metafield is not possible

Call editmode for item in a library loses original values / Saving values of new Metafield is not possible

4 posts, 0 answered
  1. Tobias
    Tobias avatar
    11 posts
    Registered:
    02 Mar 2009
    23 Apr 2009
    Link to this post
    Hello

    i have a problem editing a existing item in a library.
    I see all values for eg. description, author etc of the selected item in LibraryItemsView.
    But if i call the editmode of this item  all fields are cleared and the description field contains "Add description here".

    Second Problem.
    Also i tried to add a new Metafield for a library.
    These are the steps i processed.
    1. definition in web.config
            <add key="Libraries.ProductVersion" valueType="ShortText" visible="True" searchable="True" sortable="True" defaultValue=""/>         
     
    Library Section:
            <add name="ProductDownload" title="Product Download Library" defaultExtenstions=".zip, .rar, .exe, .msi" metaKeys="Name, Description, ProductVersion, Extension, Size"
            </add> 

    2. Changes in \Sitefinity\Admin\ControlTemplates\Libraries\LibraryItemEdit.ascx
            <sfGCn:ContentMetaFields ID="ContentMetaFields2" runat="server"
                <ItemTemplate> 
                    <h3> 
                        <asp:Literal ID="Literal21" runat="server" Text="Product Download Control"></asp:Literal></h3
                    <fieldset class="set"
                        <ol class="setIn"
                            <li> 
                                <asp:Label ID="Label13" runat="server" AssociatedControlID="ProductVersion" Text="Product Version"></asp:Label> 
                                <asp:TextBox runat="server" ID="ProductVersion"></asp:TextBox> 
                            </li> 
                        </ol> 
                    </fieldset> 
                </ItemTemplate> 
            </sfGCn:ContentMetaFields> 

    I see the new field entered a value and press the save button, but  the value i set is not saved.

    Thanks in advance!
    Tobias
  2. Stoyanka Assenova
    Stoyanka Assenova avatar
    113 posts
    Registered:
    01 Dec 2016
    24 Apr 2009
    Link to this post
    Hello Tobias,

    Which Sitefinity version do you use?

    Best wishes,
    Stoyanka Assenova
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Check out the tips for optimizing your support resource searches.
  3. Tobias
    Tobias avatar
    11 posts
    Registered:
    02 Mar 2009
    24 Apr 2009
    Link to this post
    Hello Stoyanka

    i use 3.6 without SP1.

    Greetings, Tobias
  4. Stoyanka Assenova
    Stoyanka Assenova avatar
    113 posts
    Registered:
    01 Dec 2016
    24 Apr 2009
    Link to this post
    Hi Tobias,

    This issue has been fixed in Sitefinity 3.6 SP1. We would recommend you to upgrade your project with the latest Sitefinity version (Sitefinity 3.6 SP1)

    If you have any problem, don't hesitate to contact us.

    Best wishes,
    Stoyanka Assenova
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Check out the tips for optimizing your support resource searches.
Register for webinar
4 posts, 0 answered