More in this section

Forums / Developing with Sitefinity / Edit Page Mode Not Working in 3.5

Edit Page Mode Not Working in 3.5

2 posts, 0 answered
  1. Drew
    Drew avatar
    5 posts
    Registered:
    30 Oct 2008
    10 Nov 2008
    Link to this post
    Hello,

    I am having an issue with editing a page.  If I create a page in the admin and attempt to to publish the page it does not let me.  Also, for every page that has already been created I am unable to add controls to them.  The toolbox on the right hand side of the screen does not show up.  I have created custom controls and added them to the toolbox.   It was working just fine, then all of a sudden it stopped working.  Do you have any suggestions as to why this happening?

    Thanks.
    -Drew
  2. Pepi
    Pepi avatar
    981 posts
    Registered:
    31 Jan 2017
    10 Nov 2008
    Link to this post
    Hi Drew,

    Please, check if you have set PostBackUrl property for some of the server controls. Setting this property breaks Sitefinity edit page mode.

    For the time being, the workaround is to post the information from the current page to a target page in the handler of the Button OnClick event. For example:

    .master
    <asp:Button ID="Button1" runat="server" Text="Click" OnClick="Button1_Click" /> 

    .master.cs
    protected void Button1_Click(object sender, EventArgs e) 
        Response.Redirect("~/Default.aspx"); 

    Do let us know if this is the issue.

    Greetings,
    Pepi
    the Telerik team

    Check out Telerik Trainer, the state of the art learning tool for Telerik products.
2 posts, 0 answered