More in this section

Forums / Developing with Sitefinity / Empty Locked By..

Empty Locked By..

10 posts, 0 answered
  1. Muhammad Saqib
    Muhammad Saqib avatar
    95 posts
    Registered:
    09 Sep 2009
    07 Dec 2009
    Link to this post
    Hi,
    i have a serious issue. One of my user who has the permission of View/Crate/Modify on Blogs. He has created a post and when he is trying to edit t he post the status shown is "Locked By " and there is no name that which user has locked this. so no one can edit that post except administrator.
    Please help me regarding this..
    (what i have done for now to fix this is logged in as admin and edit the post and saved again) but this is not the solution:-)
    Thanks
  2. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    12 Sep 2017
    07 Dec 2009
    Link to this post
    Hello Muhammad Saqib,

    Most probably the user that has created this post is deleted. The only way to unlock the item is using an administrator or working programmatically:

    • get the post using ContentManager
    • Save the content item with ContentStatus.Published

    Sincerely yours,
    Ivan Dimitrov
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
  3. raj
    raj avatar
    9 posts
    Registered:
    27 Jun 2012
    10 Dec 2009
    Link to this post
    Even I am facing the same issue. User who created blog/post is not deleted. Even in the history tab modifier field shows empty.
  4. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    12 Sep 2017
    10 Dec 2009
    Link to this post
    Hi raj,

    Follow the steps from the previous post. If the problem appears again, please send us the steps you have followed. Are you able to reproduce this behavior on demo.sitefinity.com which is running on build 2022 - Sitefinity 3.7 SP1?


    Regards,
    Ivan Dimitrov
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
  5. Elizabeth
    Elizabeth avatar
    83 posts
    Registered:
    23 Mar 2005
    08 Apr 2010
    Link to this post
    We have users who are having a similar problem. They are editing a blog posting and then if they have a problem (browser crashes), the posting is "locked by" and they can't edit it. I can't recreate the problem just by editing a posting and then closing my browser or navigating away without submitting or canceling the edits.
  6. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    12 Sep 2017
    08 Apr 2010
    Link to this post
    Hi Elizabeth,

    I tried to reproduce this with closing the browser, but everything looks fine when I am logged in again. If there are any certain steps we could give another try.

    Best wishes,
    Ivan Dimitrov
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
  7. raj
    raj avatar
    9 posts
    Registered:
    27 Jun 2012
    09 Apr 2010
    Link to this post

    Hi Elizabeth,

    We had similar problem and in our case it was the web garden configuration the cause of problem. We had more than one worker process configured in the IIS application pool. As soon as we changed that to one, problem got resolved.

    May be it is same in your case. Hope this helps. 
  8. Elizabeth
    Elizabeth avatar
    83 posts
    Registered:
    23 Mar 2005
    09 Apr 2010
    Link to this post

    The problem isn't with pages, but with blog postings. I was able to recreate the problem when editing a posting. I was in HTML deleting some formating tags and I got an error. We have customized error pages, so the error page didn't tell me anything, but I looked in event viewer and found the error. The problem is intermittent, I can't recreate the error every time.

    - System

      - Provider

       [ Name]  ASP.NET 2.0.50727.0
     
      - EventID 1314

       [ Qualifiers]  16384
     
       Level 4
     
       Task 3
     
       Keywords 0x80000000000000
     
      - TimeCreated

       [ SystemTime]  2010-04-09T15:57:44.000Z
     
       EventRecordID 3713
     
       Channel Application
     
       Computer HOSTWEB1
     
       Security
     

    - EventData

       4010
       An unhandled security exception has occurred.
       4/9/2010 11:57:44 AM
       4/9/2010 3:57:44 PM
       bb8cbbda4d4f4ab69db8c7d49207ba0e
       2569
       2
       0
       /LM/W3SVC/5/ROOT-1-129152152849836250
       Full
       /
       C:\inetpub\wwwroot\SANTABARBARA\
       HOSTWEB1
       
       2972
       w3wp.exe
       NT AUTHORITY\NETWORK SERVICE
       http://santabarbara.hillel.org/Sitefinity/Admin/Modules.aspx?route=BlogsControlPanel.PostsView.PostEditView&ParentId=752c2be7-b4ef-4159-a51f-facd98ce999d&Param=a23bdab1-a408-4351-9e57-aef44ccd4f33
       /Sitefinity/Admin/Modules.aspx
       66.208.13.226
       EventsBlogs
       True
       Forms
       NT AUTHORITY\NETWORK SERVICE


    As for application pools, I don't know a whole lot about IIS, but "maximum worker processes" is set to one.

  9. Elizabeth
    Elizabeth avatar
    83 posts
    Registered:
    23 Mar 2005
    30 Apr 2010
    Link to this post
    working programmatically:
     
        * get the post using ContentManager
        * Save the content item with ContentStatus.Published

    I'm still having problems with blog postings being locked, with "Locked By" empty. I would like to be able to modify the page that lists the blog posts in the admin section so that a user can unlock a blog posting. Which files/external templates would I need to modify for this page?
  10. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    12 Sep 2017
    30 Apr 2010
    Link to this post
    Hi Elizabeth,

    We were able to find what the problem is

    We are able to reproduce the issue only when

    •   he content item is programmatically edited or created.
    •   you use View_Could metakey of the Blogs Provider.  When someone views an item from the public side where you have BlogPosts control the item gets locked by unknown user and View_Count value is updated.

    In both cases
    •   context.User.Identity.Name  from the current context is String.Empty or Null - in this case the user is not logged in.

    •   IPrincipal is null,  principal.Identity.Name is null or String.Empty - the user is not logged in.

    To fix the problem is to comment the following line from your web.config in case you do not use View_Count in some implementation.

    <add key="Blogs.View_Count" valueType="Integer" visible="True" searchable="True" sortable="True" defaultValue="0"/>

    The problem fix will come with the next SP. In case you use this metakey and you cannot comment it, please open a support request.

    Best wishes,
    Ivan Dimitrov
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
Register for webinar
10 posts, 0 answered