More in this section

Forums / Developing with Sitefinity / Forum with custom Membership Provider

Forum with custom Membership Provider

2 posts, 1 answered
  1. David
    David avatar
    22 posts
    Registered:
    04 May 2009
    17 Sep 2009
    Link to this post
    I have 2 membership providers defined in my web.config.  I'm using the Sitefinity provider for logging into the CMS.  I want to use my custom provider for public users.

    I have a page which has both LoginStatus and LoginName controls.  I also have a Forums control.  When I view the page and log in, the two login controls show what I expect.  The first shows a "Logout" link and the second shows my user name.

    However, it feels like the forum thinks I'm an anonymous user.  It never shows any links to create a new thread or reply to a thread.

    Help me figure out the disconnect.
  2. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    12 Sep 2017
    17 Sep 2009
    Link to this post
    Hello David,

    To use your second provider for the front end you can set the following property Login.MembershipProvider Property

    As for the forum, you can check whether there are any permissions applied under the backend (Forums > Permissions)

    Regards,
    Ivan Dimitrov
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
    Answered
2 posts, 1 answered