More in this section

Forums / Developing with Sitefinity / Issues Installing SiteFinityCE via WebApp on 2008 R2

Issues Installing SiteFinityCE via WebApp on 2008 R2

3 posts, 0 answered
  1. Oliver Posado
    Oliver Posado avatar
    2 posts
    Registered:
    23 May 2010
    23 May 2010
    Link to this post
    Hi,
    I've been trying to get SiteFinity CE working on my 2008 R2 server. I installed it via the Web app tool so all the dependecies should be covered. I've also gone through the bullet proof tutorial for extra insights. Installation is no problem, the issues arise when I try to start (i.e browse) the site. I believe the problem is in the ASP.NET version. SF 3.7 seems to work on ASP.Net 3.5, while I have IIS 7.5 which automatically installs ASP.Net 4.0. The problem is that when the ApplicationPool is configured with v4.0 I gett the following error when browsing (where line/section # 6 is highlited on my browser):
    HTTP Error 500.19 - Internal Server Error
    The requested page cannot be accessed because the related configuration data for the page is invalid.
    Detailed Error Information
    Module  IIS Web Core
    Notification    BeginRequest
    Handler Not yet determined
    Error Code  0x800700b7
    Config Error    There is a duplicate 'system.web.extensions/scripting/scriptResourceHandler' section defined
    Config File \\?\C:\inetpub\wwwroot\SitefinityCommunityEdition\web.config
    Requested URL   http://localhost:80/SitefinityCommunityEdition/
    Physical Path   C:\inetpub\wwwroot\SitefinityCommunityEdition\
    Logon Method    Not yet determined
    Logon User  Not yet determined
    Config Source
     
        5:       <sectionGroup name="scripting" type="System.Web.Configuration.ScriptingSectionGroup, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35">
        6:         <section name="scriptResourceHandler" type="System.Web.Configuration.ScriptingScriptResourceHandlerSection, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" requirePermission="false" allowDefinition="MachineToApplication" />
        7:         <sectionGroup name="webServices" type="System.Web.Configuration.ScriptingWebServicesSectionGroup, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35">
     
    Links and More Information This error occurs when there is a problem reading the configuration file for the Web server or Web application. In some cases, the event logs may contain more information about what caused this error.
     
    View more information »

    While if I set the AppPool to use v2.0 I receive the following message (line 95 highligted):

    Server Error in '/SitefinityCommunityEdition' Application.
    Configuration Error
    Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.
     
    Parser Error Message: Could not load file or assembly 'System.Core, Version=3.5.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089' or one of its dependencies. The system cannot find the file specified.
     
    Source Error:
     
    Line 93:     <compilation debug="false">
    Line 94:       <assemblies>
    Line 95:         <add assembly="System.Core, Version=3.5.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089" />
    Line 96:         <add assembly="System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" />
    Line 97:         <add assembly="System.Xml.Linq, Version=3.5.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089" />
     
     
    Source File: C:\inetpub\wwwroot\SitefinityCommunityEdition\web.config    Line: 95
     
    Assembly Load Trace: The following information can be helpful to determine why the assembly 'System.Core, Version=3.5.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089' could not be loaded.
     
    WRN: Assembly binding logging is turned OFF.
    To enable assembly bind failure logging, set the registry value [HKLM\Software\Microsoft\Fusion!EnableLog] (DWORD) to 1.
    Note: There is some performance penalty associated with assembly bind failure logging.
    To turn this feature off, remove the registry value [HKLM\Software\Microsoft\Fusion!EnableLog].
     
     
    Version Information: Microsoft .NET Framework Version:2.0.50727.4927; ASP.NET Version:2.0.50727.4927
    Also notice that when using v2.0 I don't get an HTTP Server error 500.19, that only occurs with version v4.0
    I would appreciate any help, I'm anxious to start using SiteFinity.

    Thanx in advance
  2. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    12 Sep 2017
    24 May 2010
    Link to this post
    Hello Oliver Posado,

    Sitefinity 3.x and 4.0 CTP do not support .NET Framework 4.0 yet. There are some issues for both version. We will release a SP of 3.7 in the beginning of August and we will try to provide support for .NET Framework 4.0.

    Sitefinity 4.0 will support .NET Framework 4.0, but this will be for the BETA.

    Also there seems to be some some web.config inheritance. Try to run the project as a separate website. You may find this article useful Stopping ASP.NET web.config inheritance

    All the best,
    Ivan Dimitrov
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
  3. Oliver Posado
    Oliver Posado avatar
    2 posts
    Registered:
    23 May 2010
    24 May 2010
    Link to this post
    Thank you Ivan for your reply.However, I got Sitefinity running.
    Apparently there is an option to install ASP.Net 3.5 via the WebApp somewhere in the Web Platform -> Frameworks and Runtimes section. Once I did this, launching Sitefinity worked without a problem. However, configuring it and getting the CMS runnign also got complicated since 2008 r2 comes with SQL Server 2008r2, not SQL Server  2005/2008. I don't know if this actually implies any difference of configuration is required, but when i had to set up the SQL server and database at the configuration stage, I got some error or other that prevented me from getting it working. So I used MySQL instead, and that worked like a charm
Register for webinar
3 posts, 0 answered