More in this section

Forums / Developing with Sitefinity / RadAjaxPanel problem in IE7

RadAjaxPanel problem in IE7

2 posts, 0 answered
  1. Scott
    Scott avatar
    2 posts
    Registered:
    09 Jun 2008
    18 Jul 2008
    Link to this post
    I am trying to use a RadAjaxPanel inside a ControlTemplace e.g. ContactsListTemplate.ascx. It works fine in Firefox, but not in IE7.

    In IE when you load the page, and click on a LinkButton inside the ajax panel it will do a full postback, then if you click on the LinkButton again it behaves correctly and does a partial postback (only doing full postback the first time). However in Firefox, when you load the page and click on the LinkButton it will do a partial postback straigh away.  

    I have tried both RadAjaxPanel, RadAjaxManager. Tried using LinkButtons, ImageButtons, adding 'return false;' to OnClientClick, etc. they all produce the same result, with IE doing a full postback the first time, then partial postback. I also tried using asp:UpdatePanel, which worked correctly in both IE and Firefox.

    Any suggestions would be greatly appreciated. Here is my code:

    <telerik:RadAjaxLoadingPanel ID="LoadingPanel1" runat="server" Style="width: 320px; padding-top: 125px;" Transparency="20" Height="75px" Width="75px">
    <asp:Image id="Image1" runat="server" ImageUrl="~/RadControls/loading7.gif" ></asp:Image>
    </
    telerik:RadAjaxLoadingPanel>
    <
    telerik:RadAjaxPanel ID="radAjaxPanel1" EnableAJAX="true" runat="server" LoadingPanelID="LoadingPanel1">
    <
    asp:LinkButton ID="linkButton1" Text="click me" runat="server" />
    <
    asp:Label ID="lable1" Text="result" runat="server" />
    </
    telerik:RadAjaxPanel>

  2. Pepi
    Pepi avatar
    981 posts
    Registered:
    31 Jan 2017
    21 Jul 2008
    Link to this post
    Hello Scott,

    Unfortunately, we can not reproduce the described behavior. Please, have a look at the online examples that illustrate how to use RadAjaxPanel. If the information does not help in localizing the problem, send us a full example to test it locally.

    Thanks for your cooperation in advance.

    Greetings,
    Pepi
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
2 posts, 0 answered