More in this section
Forums / Developing with Sitefinity / Radrotator - only showing right button

Radrotator - only showing right button

The forums are in read-only mode. In case that you want to directly contact the Progress Sitefinity team use the support center. In our Google Plus group you can find more than one thousand Sitefinity developers discussing different topics. For the Stack Overflow threads don’t forget to use the “Sitefinity” tag.
4 posts, 0 answered
  1. Rhyss
    Rhyss avatar
    4 posts
    Registered:
    18 Jan 2007
    12 Jul 2010
    Link to this post
    Hi all,

    I am having an issue with using the Radrotator in my SItefinity page.  I have the databinding working and the template works ok, but i can't for the life of my figure out why the left button won't display. It displays it as having a display property set to NONE.  yet i don't set that anywhere.

    Code is:
    <div class="rotatorWrapper">
        <div class="rotatorInformation">
            <div class="rotatorInfoHeader">
                <sfWeb:GenericContent runat="server" ID="gcInfoHeader" />
            </div>
            <div class="rotatorInfoText">
                <sfWeb:GenericContent runat="server" ID="gcInfoText" />
            </div>
            <div class="rotatorInfoFooter">
            </div>
            <div class="rotatorImages">
                <telerik:RadRotator ID="RadRotator1" runat="server" RotatorType="Buttons" Width="440px"
                    Height="300px" ScrollDirection="Left" Skin="Black" WrapFrames="False" ItemHeight="300px" ItemWidth="440px">
                    <ItemTemplate>
                        <div class="rotatorItemTemplate">
                            <div class="rotatorImageTemplate">
                                <asp:Image ID="image1" runat="server" ImageAlign="left" AlternateText="image" />
                            </div>
                            <div class="rotatorTextTemplate">
                                <asp:Label CssClass="" ID="CommentInfo" runat="server" ForeColor="#66FF33" Font-Size="Large">Something</asp:Label>
                            </div>
                        </div>
                    </ItemTemplate>
                </telerik:RadRotator>
            </div>
        </div>
         
         
    </div>

    div.rotatorItemTemplate
    {
        height:300px;
        width: 440px;
     
    }
     
    div.rotatorImageTemplate
    {
        height:200px;
        width: 440px;
     
    }
     
    div.rotatorImageTemplate img
    {
        height:200px;
        width: 440px;
     
    }
     
    div.rotatorTextTemplate
    {
        text-align:center;
        padding: 10px 10px 10px 10px;
     
        width: 420px;
        height:80px;
    }

    Ideas on what is happening?
  2. Rhyss
    Rhyss avatar
    4 posts
    Registered:
    18 Jan 2007
    12 Jul 2010
    Link to this post
    I have tried it without the DIVs and just the rotator and no skin, and still the issue prevails.  Is there a javascript thing i need to check?
  3. Rhyss
    Rhyss avatar
    4 posts
    Registered:
    18 Jan 2007
    12 Jul 2010
    Link to this post
    Found what i had missed: the radrotator property as below:

    ScrollDirection="Left"

    changed to:
    ScrollDirection="Left, Right"
  4. Mark Meikle
    Mark Meikle avatar
    1 posts
    Registered:
    11 Mar 2010
    28 Dec 2010
    Link to this post
    Thank you!  This was troubling me and your solution was it.
Register for webinar
4 posts, 0 answered