More in this section
Forums / Developing with Sitefinity / RenderSelectedPageOnly and OnNeedDataSource

RenderSelectedPageOnly and OnNeedDataSource

The forums are in read-only mode. In case that you want to directly contact the Progress Sitefinity team use the support center. In our Google Plus group you can find more than one thousand Sitefinity developers discussing different topics. For the Stack Overflow threads don’t forget to use the “Sitefinity” tag.
2 posts, 0 answered
  1. bnye
    bnye avatar
    332 posts
    22 Sep 2005
    15 Oct 2007
    Link to this post
    I have a radgrid on a multipage in a Intrasite module. The OnNeedDataSource doesn't seem to fire when the multipage shows the pageview with the datagrid. Therefore in order to populate the grid the following has to be used on every page_load:

    grid1_NeedDataSource(Me.grid1, New Telerik.WebControls.GridNeedDataSourceEventArgs(GridRebindReason.InitialLoad))

    Any thoughts on how to make this more efficient would be appreciated.


  2. Yasen
    Yasen avatar
    121 posts
    18 May 2013
    19 Oct 2007
    Link to this post
    Hello bnye,

    I tried to reproduce this issue, I created a user control with a RadTabStrip, RadMultipage and RadGrid in one of the page views. However, everything is working fine in my case. I haven't set a dataSource for the grid and use the NeedDataSource event to populate the grid. The event is fired if I set AutoPostBack to true for the tab strip.

    Can you please be more specific about how exactly to reproduce this behavior (when the event is not fired).

    Kind regards,
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
2 posts, 0 answered