More in this section

Forums / Developing with Sitefinity / Solution not compiling

Solution not compiling

25 posts, 0 answered
  1. Nathan J Pledger
    Nathan J Pledger avatar
    27 posts
    Registered:
    21 Apr 2006
    06 Apr 2009
    Link to this post
    Hi,

    After MUCH struggling, I have a Visual Studio 2008 solution set up which includes a web project pointing at the SiteFinity site (including SiteFinity itself). Everything worked fine for a good few weeks.

    Now, all of a sudden I get the following compile error:

    ------ Build started: Project: D:\...\ClearVision_WEB\, Configuration: Debug .NET ------
    Validating Web Site
    Building directory '/ClearVision_WEB/App_Master/'.
    Building directory '/ClearVision_WEB/CVCmsResources/Admin/'.
    Building directory '/ClearVision_WEB/CVCmsResources/Images/'.
    Building directory '/ClearVision_WEB/CVCmsResources/Navigation/'.
    Building directory '/ClearVision_WEB/CVCmsResources/ShoppingBasket/'.
    Building directory '/ClearVision_WEB/js/'.
    Building directory '/ClearVision_WEB/Sitefinity/Admin/CmsAdmin/'.
    Building directory '/ClearVision_WEB/Sitefinity/Admin/ControlTemplates/Libraries/Dialogs/'.
    Building directory '/ClearVision_WEB/Sitefinity/Admin/ControlTemplates/Notifications/'.

    D:\dev_px\ClearVisionSiteFinity36\ClearVision_WEB\Sitefinity\Admin\ControlTemplates\Notifications\CMSSubscribersTemplate.ascx(3,19): error CS0234: The type or namespace name 'Newsletter' does not exist in the namespace 'Telerik' (are you missing an assembly reference?)
    D:\dev_px\ClearVisionSiteFinity36\ClearVision_WEB\Sitefinity\Admin\ControlTemplates\Notifications\NewslettersTemplate.ascx(4,19): error CS0234: The type or namespace name 'Newsletter' does not exist in the namespace 'Telerik' (are you missing an assembly reference?)
    Validation Complete
    ========== Build: 0 succeeded, 1 failed, 3 up-to-date, 0 skipped ==========
    ========== OpenAccess All: 0 succeeded, 0 failed, 4 skipped ==========

    This is in your code and I have changed nothing in relation to SiteFinity itself or Telerik DLLs. Was compiling fine, then added two user controls (in a separate folder and namespace, since excluded to no effect) and now doesn;t work. I am up against a deadline and can ill afford problems like this.

    Can you please advise how I can correct this?

    Many thanks,


  2. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    12 Sep 2017
    06 Apr 2009
    Link to this post
    Hello Nathan J Pledger,

    The errors you are getting are thrown from the following lines:

    CMSSubscribersTemplate.ascx
    <%@ Register TagPrefix="nsltr" Namespace="Telerik.Newsletter.WebControl" Assembly="Telerik.Notifications" %>

    NewslettersTemplate.ascx
    <%@ Register TagPrefix="nsltr" Namespace="Telerik.Newsletter.WebControl" Assembly="Telerik.Notifications" %>

    The namespace Telerik.Newsletters exists under Telerik.Notifications assemble. Make sure that you have the both lines above and Telerik.Newsletters.dll is located under your bin folder. ASP Worker process should have access over Telerik.Newsletters.dll.


    All the best,
    Ivan Dimitrov
    the Telerik team

    Check out Telerik Trainer , the state of the art learning tool for Telerik products.
  3. Nathan J Pledger
    Nathan J Pledger avatar
    27 posts
    Registered:
    21 Apr 2006
    06 Apr 2009
    Link to this post
    Hi,

    Thanks for your prompt reply.

    I have no Telerik.Newsletters.dll in my solution, nor in my original SF install. I do have Telerik.Notifications.dll in my solution. I have not changed any Telerik usercontrols, so the lines you mentioned remain:

    NewslettersTermplate:

    <%@ Register TagPrefix="nsltr" Namespace="Telerik.Newsletter.WebControl" Assembly="Telerik.Notifications" %> 
     
     

    CMSSubscribersTemplate:

    <%@ Register Assembly="Telerik.Web.UI" Namespace="Telerik.Web.UI" TagPrefix="telerik" %> 

    The DLLs are accessible by NETWORK SERVICE and I am running VS as Administrator so I can debug with IIS 7.

    Interestingly, if I exclude those two ascx files from compilation, I get a load more compilation errors but in the Feed generation parts. Something is clearly wrong!



  4. Gabe Sumner
    Gabe Sumner avatar
    440 posts
    Registered:
    09 Sep 2007
    07 Apr 2009
    Link to this post
    Hey Nathan,

    Sorry for the slow reply.  It certainly looks like you're doing the right thing; although I'm getting a different result than you.

    I downloaded a fresh Sitefinity 3.6 standard blank project.  I then loaded Visual Studio and clicked File -> Open Web Site.  I pointed to the unzipped directory for the downloaded Sitefinity Blank Project.

    After the web site was loaded, I right-clicked the solution in Solution Explorer and clicked Build Web Site.  Like you, I was also running Visual Studio as Administrator.  Everything compiled without error.

    Do you get any different results with a Sitefinity Blank Project?

    Sorry to suggest this.  I'm stabbing in the dark and trying to think of troubleshooting tests that will tell us more about the problem.

    Gabe Sumner
    http://www.sitefinitywatch.com/
  5. Nathan J Pledger
    Nathan J Pledger avatar
    27 posts
    Registered:
    21 Apr 2006
    07 Apr 2009
    Link to this post
    Hi Gabe,

    Many thanks for looking into this. It's very close to a deadline for me and I didn't want to have to bail on SiteFinity this late in the day.

    Due to the time constraints I have decided to split my VS solution by:

    - launching where I managed to get up to onto my staging server
    - deleting all SF code from the solution so the solution/web site compiles
    - retaining DLLs and web.config
    - create a web form as a test harness
    - build components as user controls and ship up to staging server individually.

    This is not an ideal solution by any stretch but luckily I have passed the point of having to "talk" to SF itself, my remaining code is related to other resources.

    Thanks for your suggestion about a blank web project. This had crossed my mind. Even getting  a blank project was an exercise in frustration, to be honest. I ended up downloading and setting up the blank SF project on a Windows XP VM with IIS6, then copying to my IIS7 and applying Classic Pipeline Mode, etc. If I struggle any more with this, I'll have to revisit this.

    Thanks again for your help. I'll be happy to let you know how it goes/provide feedback from myself and my client if you're interested.

  6. Georgi
    Georgi avatar
    3583 posts
    Registered:
    28 Oct 2016
    08 Apr 2009
    Link to this post
    Hello,

    We are interested in any problems or suggestions you might have. We encourage you to let us know about anything that bothers you or your clients - we will try to provide you as much accurate assistance as possible.

    Thank you.

    All the best,
    Georgi
    the Telerik team

    Check out Telerik Trainer , the state of the art learning tool for Telerik products.
  7. Mark
    Mark avatar
    4 posts
    Registered:
    23 Nov 2008
    29 Apr 2009
    Link to this post
    Hi All,

    Its not just Nathan, I too am having issues when compiling the blank solution.

    I followed Gabe's step by step...

    Downloaded Sitefinity_3_6_1920_standard_BlankProject.zip

    Extracted to a folder, open up the website with Visual Studio (tried both VS05 and VS08) and Built the website and I still get the errors.

    I also tried the Sitefinity_3_6_1920_standard_NET20_BlankProject.zip version to no avail.

    As Nathan mentions there is no Telerik.Newsletters.dll in the /bin folder... just the Telerik.Notifications.dll.

    <%@ Register TagPrefix="nsltr" Namespace="Telerik.Newsletter.WebControl" Assembly="Telerik.Notifications" %>

    I opened up the Telerik.Notifications.dll using Reflector.NET as the line generating the error references the Telerik.Notifications assembly rather than Telerik.Newsletter.

    When viewing Telerik.Notifications assembly there is a namespace called Telerik.Newsletter but not Telerik.Newsletter.WebControl.

    Can you guys please check that the 3.6.1920 version is correct?

    Regards,
    Mark Arrowsmith

  8. Nathan J Pledger
    Nathan J Pledger avatar
    27 posts
    Registered:
    21 Apr 2006
    29 Apr 2009
    Link to this post
    Hi Mark,

    Thanks for joining the thread :)

    My situation occurred spontaneously (obviously some setting might have changed as a result of some update/incompetence on my part - but I fail to see how). Did yours occur all on its own, with no code update (of your own or Telerik's code)  between compiles? I find it very odd that it wasn't as a result of updating any code!

    So far, I have managed to work out of a test harness, but I feel my days are numbered on this. News of a service pack update fills me with fear in that I may have to do it all over again! (I have to build SiteFinity on an XP VM then stick it on USB disk, then movet o my Vista dev machine)

    Telerik guys: We're still working on content management aspects of the site and feedback is coming. Immediately obvious to me at the moment is the installation process is a nightmare (particularly on Vista) and ability to move content elements up/down within a placeholder using a method other than drag-and-drop (which I can't get to work reliably anyway) would be a useful fallback.

    Anyway, back to the original product Mark and I are experiencing ....

  9. Mark
    Mark avatar
    4 posts
    Registered:
    23 Nov 2008
    29 Apr 2009
    Link to this post
    Hi Nathan,

    No I havent made any modifications to the blank project and I still get the errors.

    SiteFiinity Newbee here .. lol

    The company I work for has decided to try developing a project for a client in SiteFinity rather than DotNetNuke as we have done for several past projects.

    I am running XP Professional SP 3 and using Visual Studio 2005 Professional Edition and also Visual Studio 2008 Standard Edition.

    I have installed SiteFinity 3.6 using the .exe but have also attempted to create a SiteFinity project from the blank project template hence this thread.

    A similiar (if not the same) error occurs when I visit the Newsletter section in the Administration section of a site I created using the SiteFinity Project Manager.
    http://localhost/MaterPrizeHome/Sitefinity/Admin/Modules.aspx?module=Newsletters

    Compilation Error

    Description: An error occurred during the compilation of a resource required to service this request. Please review the following specific error details and modify your source code appropriately.

    Compiler Error Message: CS0234: The type or namespace name 'Newsletter' does not exist in the namespace 'Telerik' (are you missing an assembly reference?)

    Source Error:


    Line 2:      Namespace="System.Web.UI" TagPrefix="asp" %>
    Line 3: <%@ Register TagPrefix="sfMsg" Namespace="Telerik.Cms.Web.UI" Assembly="Telerik.Cms.Web.UI" %>
    Line 4: <%@ Register TagPrefix="nsltr" Namespace="Telerik.Newsletter.WebControl" Assembly="Telerik.Notifications" %>
    Line 5: <div class="ToolsAll">
    Line 6: <asp:LinkButton ID="CreateNewNewsletter" runat="server" CssClass="CmsButLeft new"

    Source File: c:\Program Files\telerik\Sitefinity3.6\WebSites\MaterPrizeHome\Sitefinity\Admin\ControlTemplates\Notifications\NewslettersTemplate.ascx    Line: 4

    Please Note: I have made no code modifications to either the blank projects I have created or the one done through Project Manager.

    I hope all this information helps.

    Cheers,
    Mark

  10. Mark
    Mark avatar
    4 posts
    Registered:
    23 Nov 2008
    30 Apr 2009
    Link to this post
    Hi All,

    I was able to get the Blank Project to compile successfully by making the following changes:

    \Sitefinity\Admin\ControlTemplates\Notifications\CMSSubscribersTemplate.ascx Ln3 
    From: <%@ Register TagPrefix="nsltr" Namespace="Telerik.Newsletter.WebControl" Assembly="Telerik.Notifications" %> 
    To:   <%@ Register TagPrefix="nsltr" Namespace="Telerik.Notifications.Newsletters.WebControl" Assembly="Telerik.Notifications" %> 
     
    \Sitefinity\Admin\ControlTemplates\Notifications\NewslettersTemplate.ascx Ln4 
    From: <%@ Register TagPrefix="nsltr" Namespace="Telerik.Newsletter.WebControl" Assembly="Telerik.Notifications" %> 
    To:   <%@ Register TagPrefix="nsltr" Namespace="Telerik.Notifications.Newsletters.WebControl" Assembly="Telerik.Notifications" %> 
     
    \Sitefinity\Admin\ControlTemplates\RssFeeds\ViewFeeds.ascx Ln22 
    From: <runat="Server" id="P2"><asp:HyperLink runat="server" Text='<%# Eval("Url") %>' NavigateUrl='<%# Page.ResolveUrl(Eval("Url")) %>' rel="external"></asp:HyperLink></p
    To:   <runat="Server" id="P2"><asp:HyperLink runat="server" Text='<%# Eval("Url") %>' NavigateUrl='<%# Page.ResolveUrl(Eval("Url").ToString()) %>' rel="external"></asp:HyperLink></p
     
    \Sitefinity\Admin\ControlTemplates\Showcases\ControlPanelEdit.ascx  
    Ln64 
    From: <li><p class="imgThumbnail"><asp:Image runat="server" ImageUrl='<%# Eval("Url") + Eval("ContentProvider.ThumbnailExtension") %>' /></p></li> 
    To:   <li><p class="imgThumbnail"><asp:Image runat="server" ImageUrl='<%# Eval("Url").ToString() + Eval("ContentProvider.ThumbnailExtension").ToString() %>' /></p></li> 
    Ln351 
    From: <class="imgThumbnail"><asp:Image runat="server" ID="screenshotImage" ImageUrl='<%# Eval("Url") + Eval("ContentProvider.ThumbnailExtension") %>' /></p
    To:   <class="imgThumbnail"><asp:Image runat="server" ID="screenshotImage" ImageUrl='<%# Eval("Url").ToString() + Eval("ContentProvider.ThumbnailExtension").ToString() %>' /></p
    Ln352 
    From: <em class="originalSize"><asp:HyperLink ID="HyperLink1" runat="server" CssClass="newWind" NavigateUrl='<%# Eval("Url") + Eval("ContentProvider.ContentExtension") %>' Text="View Original"></asp:HyperLink><%# Eval("Width") %> x <%# Eval("Height") %></em
    To:   <em class="originalSize"><asp:HyperLink ID="HyperLink1" runat="server" CssClass="newWind" NavigateUrl='<%# Eval("Url").ToString() + Eval("ContentProvider.ContentExtension").ToString() %>' Text="View Original"></asp:HyperLink><%# Eval("Width") %> x <%# Eval("Height") %></em
     
    \Sitefinity\ControlTemplates\Testimonials\SubmitTestimonial.ascx Ln46 
    From: // $find("<%= testimonialMultiPage.FindPageViewByID("mainView").FindControl("testimonialMetaFields").Controls(0).FindControl("pictureUploader").ClientID %>").clearFileInputAt(0); 
    To:   // $find("<%-- testimonialMultiPage.FindPageViewByID("mainView").FindControl("testimonialMetaFields").Controls(0).FindControl("pictureUploader").ClientID --%>").clearFileInputAt(0); 
     

    Hope this helps you Nathan!

    Cheers,
    Mark
  11. Pepi
    Pepi avatar
    981 posts
    Registered:
    31 Jan 2017
    30 Apr 2009
    Link to this post
    Hi Nathan,

    You could just delete the registration causing the error from the following files:
    ~/Sitefinity/Admin/ControlTemplates/Notifications/CMSSubscribersTemplate.ascx

    ~/Sitefinity/Admin/ControlTemplates/Notifications/NewslettersTemplate.ascx


    <%@ Register TagPrefix="nsltr" Namespace="Telerik.Newsletter.WebControl" Assembly="Telerik.Notifications" %> 
     

    It is not necessary to fix it (as Mark suggests) as it is used nowhere in the Newsletters templates.

    Let us know if you experience any other problems.

    Regards,
    Pepi
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Check out the tips for optimizing your support resource searches.
  12. Nathan J Pledger
    Nathan J Pledger avatar
    27 posts
    Registered:
    21 Apr 2006
    02 May 2009
    Link to this post
    Hi Pepi,

    Thanks for your reply.

    Having got the chance to try your solution, I actually remember having tried fiddling with these directives in a bid to resolve the problem. It did indeed remove the two errors in question.

    Now, I get 206 errors:

    Error 11 The best overloaded method match for 'System.Web.UI.Control.ResolveUrl(string)' has some invalid arguments D:\dev_px\ClearVisionSiteFinity36\ClearVision_WEB\Sitefinity\Admin\ControlTemplates\RssFeeds\ViewFeeds.ascx 22
    Error 12 Argument '1': cannot convert from 'object' to 'string' D:\dev_px\ClearVisionSiteFinity36\ClearVision_WEB\Sitefinity\Admin\ControlTemplates\RssFeeds\ViewFeeds.ascx 22
    Error 13 Syntax error. D:\dev_px\ClearVisionSiteFinity36\ClearVision_WEB\Sitefinity\Admin\ControlTemplates\Notifications\CMSSubscribersTemplate.ascx 1 1 D:\...\ClearVision_WEB\
    Error 14 Syntax error. D:\dev_px\ClearVisionSiteFinity36\ClearVision_WEB\Sitefinity\Admin\ControlTemplates\Notifications\CMSSubscribersTemplate.ascx 1 1 D:\...\ClearVision_WEB\
    Error 15 Syntax error. D:\dev_px\ClearVisionSiteFinity36\ClearVision_WEB\Sitefinity\Admin\ControlTemplates\Notifications\CMSSubscribersTemplate.ascx 1 1 D:\...\ClearVision_WEB\

    ... snip .....

    Error 212 End of statement expected. D:\dev_px\ClearVisionSiteFinity36\ClearVision_WEB\Sitefinity\Admin\ControlTemplates\Notifications\NewslettersTemplate.ascx 1 1 D:\...\ClearVision_WEB\
    Error 213 Declaration expected. D:\dev_px\ClearVisionSiteFinity36\ClearVision_WEB\Sitefinity\Admin\ControlTemplates\Notifications\NewslettersTemplate.ascx 1 1 D:\...\ClearVision_WEB\
    Error 214 Declaration expected. D:\dev_px\ClearVisionSiteFinity36\ClearVision_WEB\Sitefinity\Admin\ControlTemplates\Notifications\NewslettersTemplate.ascx 1 1 D:\...\ClearVision_WEB\
    Error 215 Syntax error. D:\dev_px\ClearVisionSiteFinity36\ClearVision_WEB\Sitefinity\Admin\ControlTemplates\Notifications\NewslettersTemplate.ascx 1 1 D:\...\ClearVision_WEB\
    Error 216 Maximum number of errors has been exceeded. D:\...\ClearVision_WEB\

    I've also upgraded to the latest version (3.6 SP 1 Hotfix).

    Back to plan B ...

  13. Georgi
    Georgi avatar
    3583 posts
    Registered:
    28 Oct 2016
    06 May 2009
    Link to this post
    Hi Nathan J Pledger,

    Could you please let us know about the exact upgrade path and versions that you used. The previous reply had to resolve the problem.

    Sincerely yours,
    Georgi
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Check out the tips for optimizing your support resource searches.
  14. Nathan J Pledger
    Nathan J Pledger avatar
    27 posts
    Registered:
    21 Apr 2006
    06 May 2009
    Link to this post
    Hi,

    The version path was 3.6, then 3.6 SP1 Hotfix version.

    I used blank projects throughout.

    I've modified no SIteFinity code, or added any extensions/modules, etc. of my own other than basic UserControls which have no problems.


  15. Georgi
    Georgi avatar
    3583 posts
    Registered:
    28 Oct 2016
    09 May 2009
    Link to this post
    Hello Nathan J Pledger,

    I am attaching the Notifications control templates taken from a Sitefinity 3.6SP1 Hotfix standard edition. I tested a blank project with them, and it compiled just fine.

    Please backup yours, and try to use these ones. Their location should be Sitefinity\Admin\ControlTemplates\Notifications

    Let me know about the results.

    Regards,
    Georgi
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Check out the tips for optimizing your support resource searches.
  16. Nathan J Pledger
    Nathan J Pledger avatar
    27 posts
    Registered:
    21 Apr 2006
    05 Sep 2009
    Link to this post
    Hi Georgi,

    This continues to not work. I am now finding this very frustrating as I really could do with this manner of working to work as it should, particularly as I have to implement some user account code myself which I think really should have been within SiteFinity itself.

    (See http://www.sitefinity.com/support/forums/sitefinity-3-x/security/create-user-wizard-displays-even-for-logged-in-users.aspx)

    I have applied your latest templates with the same result.

    This is a brand new Windows 7 build, with the complete and working web site added to a Visual Studio solution.

    I have taken a screenshot, which you can view at: http://programx.co.uk/media/p/3919.aspx

    I can make a ZIP available of the solution if this would help. Obviously, now I have no Support options I'm not sure if you're going to be willing to accept this as a means of identifying the problem.

    Thanks,

    Nathan
  17. Nathan J Pledger
    Nathan J Pledger avatar
    27 posts
    Registered:
    21 Apr 2006
    05 Sep 2009
    Link to this post
    Hi,

    Hiding the SiteFinity folder in Windows Explorer and re-loading Visual Studio stops VS from seeing it and therefore doesn't compile its contents. This does not solve the problem, though.
  18. Georgi
    Georgi avatar
    3583 posts
    Registered:
    28 Oct 2016
    07 Sep 2009
    Link to this post
    Hi Nathan J Pledger,

    You could just deletethe registration causing the error from the following files:

    ~/Sitefinity/Admin/ControlTemplates/Notifications/CMSSubscribersTemplate.ascx
    ~/Sitefinity/Admin/ControlTemplates/Notifications/NewslettersTemplate.ascx

    <%@ Register TagPrefix="nsltr"Namespace="Telerik.Newsletter.WebControl"Assembly="Telerik.Notifications" %>      

    It is not necessary to fix it as it is used nowhere in the Newsletterstemplates. The official resolution though is to update your project, and the templates you use. 

    Let us know if you experience any other problems.

    Greetings,
    Georgi
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
  19. Jason Yeager
    Jason Yeager avatar
    3 posts
    Registered:
    14 Jan 2009
    23 Sep 2009
    Link to this post
    Why is this still a problem when doing a fresh install of SiteFinity?  If the fix is to delete the offending template files, why are they STILL included in new releases?  I just did a fresh install of 3.7 sp1 and have to 'fix' these errrors myself.....again. 

    Just a suggestion, but you might want to fix this in your source code.....

    Jason

  20. Georgi
    Georgi avatar
    3583 posts
    Registered:
    28 Oct 2016
    25 Sep 2009
    Link to this post
    Hello Jason Yeager,

    The truth is that the warnings blurred with the rest of the notifications Visual Studio outputs. We haven't fixed all warnings - they do not stop you to compile and actually run Sitefinity in anyway. We will those two templates though.

    Sincerely yours,
    Georgi
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
  21. Jason Yeager
    Jason Yeager avatar
    3 posts
    Registered:
    14 Jan 2009
    25 Sep 2009
    Link to this post
    Thank you for the quick response.

    For me, and I believe all on this thread, Visual Studio will not compile and throws an error, not just a warning.  I also have to fix issues on 3 other templates before SiteFinity will run.  Next time I do a fresh install, I will document all of the items and post them to you.  I use the 3.5 blank project version and run it as a web site.

    Once I get past the items above, Sitefinity runs great and is a very good product. 

    Thanks,
    Jason
  22. Georgi
    Georgi avatar
    3583 posts
    Registered:
    28 Oct 2016
    26 Sep 2009
    Link to this post
    Hi Jason Yeager,

    That's strange - it is just warnings on my side.

    For Sitefinity 4.0, we will treat all warnings as errors. Perhaps your visual studio is enabled to treat the warnings in the same way. 

    Thank you once again for your feedback and commitment to help!

    Kind regards,
    Georgi
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
  23. David Shirley
    David Shirley avatar
    1 posts
    Registered:
    25 Jun 2009
    01 Oct 2009
    Link to this post
    Hi SiteFinity Support Team,

    Yes there still are errors in the latest blank website template: Sitefinity_3_7_2022_standard_BlankProject.zip

    To see them you need to enable the validation of the website during the build process.
    Right click on the Website and go to its Property Pages.... Click on the "Build" sub menu and ensure that the "Build Web site as part of solution" is checked and Build the Solution.

    You will then see the errors we have to fix every time.

    As a personal preference I prefer "Web Application" projects over "Web Site" projects for just this issue, Web Application projects always get fully built to ensure you won't miss any compile time errors. Just need to watch the runtime

    Kind Regards,
    Mark Arrowsmith
  24. Georgi
    Georgi avatar
    3583 posts
    Registered:
    28 Oct 2016
    01 Oct 2009
    Link to this post
    Hi David Shirley,

    Thank you for the screenshot.
    You will be able to choose if you want a web site or an web application from the project manager. 

    As for the errors, we will definitely fix them and try to distribute them in the next update. 

    Greetings,
    Georgi
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
  25. Kieran
    Kieran avatar
    56 posts
    Registered:
    14 Aug 2008
    25 Feb 2010
    Link to this post
    Hey

    I too was getting  this error, my issue was that there was a web.config file in the root folder so was over writting the main projects web.config. Once I removed it sitefinity work away again.


    Kieran
Register for webinar
25 posts, 0 answered