More in this section

Forums / Developing with Sitefinity / Still keeping Error

Still keeping Error

2 posts, 0 answered
  1. Daravuth
    Daravuth avatar
    1 posts
    Registered:
    26 Feb 2008
    13 Mar 2008
    Link to this post
    Hello! I am new to sitefinity. Currently, i have read through its user manual documentation. I followed some steps. Some are able to work but some gets many errors.

    Recently, i reach the Adding Providers section. I tried to follow step by step as the document says. I tried to add the Breaking_News in the news module. It works with the interface which means after reaching the last step, i saw there are two options : News and Breaking News to choose.

    When selection the most recent created Breaking News, i got errrors :

    A required control was not found in the template for "Telerik.Cms.Engine.WebControls.Admin.ControlPanel+ListContainer". The control must be assignable form type "System.Web.UI.WebControls.IButtonControl" and must have ID "createNewButton".

    I really wonder whether it's coz of the community version which doesn't support this feature or i do any errors.

    Suggestion ??

    Thanks!!

    PS : I am using the Community Version : 3.1 SP2




  2. Pepi
    Pepi avatar
    981 posts
    Registered:
    31 Jan 2017
    13 Mar 2008
    Link to this post
    Hello Daravuth,

    The only reason for this exception is that it cannot find the necessary template (~/Sitefinity/Admin/ControlTemplates/News/ControlPanelList.ascx) and tries to load the default one that has no implementation. Did you copy the News folder located respectively in ~/Sitefinity/Admin/ControlTemplates/ and ~/Sitefinity/ControlTemplates/ directories and rename it to Breaking_News? This is necessary because the default template paths for the News module are generated automatically based on the provider name. In your case it is Breaking_News.

    Do let us know how it goes.

    Regards,
    Pepi
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
2 posts, 0 answered