More in this section

Forums / Developing with Sitefinity / The specified string is not in the form required for an e-mail address.

The specified string is not in the form required for an e-mail address.

4 posts, 0 answered
  1. Mike
    Mike avatar
    221 posts
    Registered:
    19 Aug 2008
    25 Feb 2009
    Link to this post
    So, i just managed to get my Newsletter module up and running and i go to setup the SMTP server and send something out... And i get the following error:

    The specified string is not in the form required for an e-mail address.

    I then try to continue on by hitting the Activate button and get this:

    Failed to activate, please verify your SMTP setting and try again

    I currently have another class working as my mail utility running the exact same setting and mail works...

    So i went into the web.config to set ti there as described here:
    http://www.sitefinity.com/sf3/faq.html#118

    No change... Am i missing something here?

    Duncan
  2. Nikolai
    Nikolai avatar
    216 posts
    Registered:
    01 Jun 2017
    26 Feb 2009
    Link to this post
    Hi Duncan,

    I suppose that the problem with validation comes from the SMTP Username field. It requires whole e-mail to work like name@domain.com
    If this is not the problem please write us back.

    Kind regards,
    Nikolai
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Check out the tips for optimizing your support resource searches.
  3. Mike
    Mike avatar
    221 posts
    Registered:
    19 Aug 2008
    26 Feb 2009
    Link to this post
    hmmm ok, never used an email address for the username before... But that did work...

    I now gettign the follwoign error when sending the newsletter:

    Sys.WebForms.PageRequestmanagerParserErrorException: The message recieved fromt he server could not be parsed. Common causes for this error are when the response is modified by calls to Response.Write(), response filters, HttpModules, or server trace is enabled.
    Details: Error parsing near '<html>
    <head>
    '.


    The message appears in a popup and clicking ok only brings the message back up...

    The newsletter actually sends successfully though...

    Any idea how i can resolve this one?

    Duncan
  4. Georgi
    Georgi avatar
    3583 posts
    Registered:
    28 Oct 2016
    03 Mar 2009
    Link to this post
    Hi Duncan,

    We found that this is an MS Ajax issue, which is also related to the ASP.NET RoleManagerModule http module (you can see the actual exception in the ~/App_Data/sitefinity.log file). This is fixed in some of the .net service packs, and for sure in the .NET 3.5 Ajax Web Extensions.
    We found a workaround for it - set cacheRolesInCookie attribute of the system.web/roleManager to false in the web.config:
    <roleManager enabled="true" cacheRolesInCookie="false" defaultProvider="Sitefinity">  

    Let us know about the results this time.

    Kind regards,
    Georgi
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Check out the tips for optimizing your support resource searches.
Register for webinar
4 posts, 0 answered