More in this section

Forums / Developing with Sitefinity / Unable to change permission to stop publishing

Unable to change permission to stop publishing

2 posts, 0 answered
  1. Emma
    Emma avatar
    2 posts
    Registered:
    10 Jun 2008
    10 Jun 2008
    Link to this post
    Even when the admin account checks the deny box on publish and appoval for "Editors" they are still able to publish, and the the publiush button doesn't change to "send for approval".
     I'm not able to get any other type of status other than published. This is using both Firefox and Explorer on Vista, and logging out as one user to another in the same browser session and in different browser sessions.
  2. Rebecca
    Rebecca avatar
    536 posts
    Registered:
    24 Sep 2012
    11 Jun 2008
    Link to this post
    Hi Emma,

    Thank you for your interest in Sitefinity and getting in touch with us.

    Most probably, you are mislead by the Publish button, which is equal in function toSave when page workflow is not enabled. Please enable page workflow in the application web.config file as shown below:

    <cms defaultProvider="Sitefinity" useStrictLanguageVersions="true" 
         pageExtension=".aspx"   
         projectName="Test" disabled="false"   
         pageEditorUIMode="Overlay">  
          <providers> 
            <clear /> 
            <add connectionStringName="DefaultConnection"   
             allowPageHistory="true" 
             allowPageWorkflow="true"   
             name="Sitefinity"   
             type="Telerik.Cms.Data.DefaultProvider, Telerik.Cms.Data" /> 

    Do not hesitate to contact us again if you need any further assistance.

    All the best,
    Rebecca
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
2 posts, 0 answered