More in this section
Forums / General Discussions / 403 - Forbidden: No Permission to view directory or page

403 - Forbidden: No Permission to view directory or page

The forums are in read-only mode. In case that you want to directly contact the Progress Sitefinity team use the support center. In our Google Plus group you can find more than one thousand Sitefinity developers discussing different topics. For the Stack Overflow threads don’t forget to use the “Sitefinity” tag.
7 posts, 0 answered
  1. Eric
    Eric avatar
    147 posts
    12 Nov 2007
    10 Mar 2011
    Link to this post
    I created a page back on January 24th. Suddenly this week I'm getting an HTTP error 403 (forbidden) on it, last week it worked fine. The page inherits permissions from its parent and I can access other pages in the same folder (who also inherit permissions).

    I created a new page and I can access it. I deleted the old page and renamed the new page and I can get to the page again.

    Anybody seen this? Is there a reason for this? I'd hate to have this site in production and pages start returning 403s.


    IIS 7.0 Detailed Error Information
    Module: ManagedPipelineHandler
    Notification: ExecuteRequestHandler
    Handler: ASP.sfres_telerik_sitefinity_resources_sitefinitydefault_aspx
    Error code: 0x00000000
    Requested: http://mysite:80/policy/quote-results?depart=3%2f30%2f2011&return=3%2f31%2f2011&state=521&cost1=2000&age1=33&cost2=2000&age2=38&n=2
    Physical Path: c:\Sitefinity\policy\quote-results
    Logon method: Sitefinity
    Logon user: Anonymous
  2. Stephen
    Stephen avatar
    14 posts
    12 Jan 2011
    11 Mar 2011
    Link to this post
    Have you upgraded to SP1?

    SP1 introduced a bug where a page not marked as "Show in navigation" will return a 403 error to anonymous users.

    We've had to mark all pages as "Show in navigation" and then within the navigation controls, manually select the pages that will be shown on site.
  3. Eric
    Eric avatar
    147 posts
    12 Nov 2007
    11 Mar 2011
    Link to this post
    I have upgraded to SP1. The page I created had "Show in Navigation" but it's possible the previous page did not. I'll take another look at this (there were other affected pages).

  4. Kristian
    Kristian avatar
    214 posts
    03 Jun 2010
    13 Mar 2011
    Link to this post
    Yea I ran into this problem to with SP1
  5. Georgi
    Georgi avatar
    3583 posts
    28 Oct 2016
    15 Mar 2011
    Link to this post
    Hi Kristian,

    We have just fixed this error with this week's internal release. Please check the full release notes here -

    Kind regards,
    the Telerik team
  6. Sean
    Sean avatar
    1 posts
    06 Jul 2010
    05 Apr 2011
    Link to this post
    Nice to know there's a fix in the internal build. For those of us who are about to put a SP 1 site into production for a client, is there a workaround? Also, when will the next SP be released?
  7. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    12 Sep 2017
    06 Apr 2011
    Link to this post
    Hi Sean,

    We are going to release the Q1 next week, so I suggest that you should upgrade your project to it instead of applying SP1. This fix and many other will be included in Q1. There will be a new features as well.

    Best wishes,
    Ivan Dimitrov
    the Telerik team

7 posts, 0 answered