More in this section

Forums / General Discussions / 500 Error for PUT requests on services

500 Error for PUT requests on services

5 posts, 0 answered
  1. Bryan
    Bryan avatar
    62 posts
    Registered:
    20 Jul 2010
    12 Apr 2011
    Link to this post
    I just deployed a SF 4 installation to a shared hosted server and all services in the back end are raising 500 errors when I try to update anything.  The verb always appears to be a PUT.  However, POST seems to work just fine.

    Any ideas?
  2. Boyan Barnev
    Boyan Barnev avatar
    1429 posts
    Registered:
    28 Aug 2017
    12 Apr 2011
    Link to this post
    Hello Bryan,

    There is most likely a problem with the mappings to the .svc and .xamlx extensions in IIS. Can you please make sure you have everything set up as per the instructions on this page of our Installation and Administration guide?  If this does not fix the problem, could you please record a trace of the web service exceptions that occur while browsing the problematic content on your site (you can refer to this KB article for more information on how to do this). Also please make sure that in your mappings for .svc and .xamlx extensions in IIS you do not have restrictions over the verbs. If you have WebDAV module enabled in IIS you will have to disable if for your Sitefinity website as WebDAV module forbits PUT verb.

    Greetings,
    Boyan Barnev
    the Telerik team

  3. Bryan
    Bryan avatar
    62 posts
    Registered:
    20 Jul 2010
    12 Apr 2011
    Link to this post
    This is on a shared host.  I am using IIS manager to do the configuration and I believe the .svc mapping is correct.  There is a handler svc-ISAPI-4.0_64bit that is mapped to *.svc.  On the Verbs tab for this mapping, the "All verbs" is selected.

    I am not sure how to disable WebDAV.  So if I am using IIS manager to manage the configuration, does this mean WebDAV is enabled?

    Thanks.
  4. Bryan
    Bryan avatar
    62 posts
    Registered:
    20 Jul 2010
    12 Apr 2011
    Link to this post
    I enabled tracing and the errors/warnings I am getting are:

    <EventID>524312</EventID>
    <Type>3</Type>
    <SubType Name="Warning">0</SubType>
    <Level>4</Level>
    <TimeCreated SystemTime="2011-04-12T17:57:14.6479819Z" />
    <Source Name="System.ServiceModel" />
    <Correlation ActivityID="{4d4903f3-7720-4455-a405-eb1cacdfa9ae}" />
    <Execution ProcessName="w3wp" ProcessID="16596" ThreadID="19" />
    <Channel />
    <Computer>H7838-6</Computer>
    </System>
    <ApplicationData>
    <TraceData>
    <DataItem>
    <Description>Configuration evaluation context not found.</Description>
    <AppDomain>/LM/W3SVC/534/ROOT-1-129471044017236490</AppDomain>
    </TraceRecord>
    </DataItem>
    </TraceData>
    </ApplicationData>
    </E2ETraceEvent>

    My configuration is the same, with the exception of connection strings, between my internal staging server and the hosting provider.
  5. Boyan Barnev
    Boyan Barnev avatar
    1429 posts
    Registered:
    28 Aug 2017
    13 Apr 2011
    Link to this post
    Hello Bryan,

    Did you follow the KB article about tracing web service exceptions that I asked you? Can you please send me the SdrConfigExample.e2e file that was generated in the root folder of your project, since it contains all the trace data in form of exceptions, stack traces and other helpful information that can lead us to the root of this problem. This KB article explains how to disable WebDAV module from your web.config. Also you can check this IIS related forum thread.

    Greetings,
    Boyan Barnev
    the Telerik team

5 posts, 0 answered